This package contains dart.js, and previously contained interop.js
The dart.js file is used in Dart browser apps to check for native Dart support and either (a) bootstrap Dartium or (b) load compiled JS instead. Previously, we've recommended that you add a script tag pointing the version of dart.js in our repository. This doesn't work offline and also results in slower startup (see dartbug.com/6723).
Instead, we now recommend that you install dart.js via the following steps:
Add the following to your pubspec.yaml: dependencies: browser: any
Run pub install.
Use a relative script tag in your html to the installed version:
If you do not wish to use pub, you may host a copy of this file locally instead. In this case, you will need to update it yourself as necessary. We reserve the right to move the old file in the repository, so we no longer recommend linking to it directly.
This script was required for dart:js interop to work, but it is no longer needed. The functionality is now supported by dart:js directly.
If you previously had a script such as this, please remove it:
Add this to your package's pubspec.yaml file:
dependencies: browser: ">=0.10.0+2 <0.11.0"
If you're using the Dart Editor, choose:
Menu > Tools > Pub Install
Or if you want to install from the command line, run:
$ pub install
|0.10.0+2||Mar 18, 2014||Download browser 0.10.0+2 archive|
|0.10.0+1||Mar 18, 2014||Download browser 0.10.0+1 archive|
|0.10.0||Feb 28, 2014||Download browser 0.10.0 archive|
|0.9.1||Jan 02, 2014||Download browser 0.9.1 archive|
|0.9.0||Nov 06, 2013||Download browser 0.9.0 archive|
|0.8.10+4||Nov 05, 2013||Download browser 0.8.10+4 archive|
|0.8.10+3||Nov 04, 2013||Download browser 0.8.10+3 archive|
|0.8.10||Nov 01, 2013||Download browser 0.8.10 archive|
|0.8.9||Oct 31, 2013||Download browser 0.8.9 archive|
|0.8.8||Oct 30, 2013||Download browser 0.8.8 archive|