do_dart BETA

Pub support

A Dart SDK for the DigitalOcean Api v2

dependencies:
  do_dart: ^0.1.2 #latest version

Easy to use

To get started, you need a DigitalOcean API key with sufficient privileges for the tasks you want to perform.

Then: Initializing the client

import 'package:do_dart/do_dart.dart';

Client client = Client(<DigitalOcean API Key>);

Examples

Initializing the client

import 'package:do_dart/do_dart.dart';

Client client = Client(<DigitalOcean API Key>);

Creating a droplet

DropletCreateRequest dcr =
        DropletCreateRequest("test-droplet", 'nyc1', 's-1vcpu-1gb', 43515152, ssh_keys: [<SSH KEY ID or Fingerprint]);

Droplet d = await client.droplet.create(dcr);

The license is MIT.

Features and bugs

Please file feature requests and bugs at the issue tracker.

Libraries

do_dart
DO-Dart is an implementation of the DigitalOcean api in Dart. It aims to enable developers such as me to interact with DigitalOcean API