kotlin.dart

Pub

Deprecated

Notice

This project does not convert Kotlin to Dart. To prevent that confusion it was renamed.

Please migrate to kt.dart

This package has been renamed to kt.dart. All code can be found here.

Upgrade

pubspec.yaml

dependencies:
-  kotlin_dart: ^0.4.0
+  kt_dart: ^0.5.0

your_source.dart

- import 'package:kotlin_dart/kotlin.dart';
+ import 'package:kt_dart/kt.dart';

License

Copyright 2019 Pascal Welsch

Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at

   http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
See the License for the specific language governing permissions and
limitations under the License.

Libraries

kotlin_dart
kt_annotation
kt_collection
kt_exception