validators

Build Status

String validation and sanitization for Dart. Dart 2-compatible version of validator

Port of chriso's library.

Usage

1. Add dependency to your package's pubspec.yaml file:

dependencies:
  validators: ^2.0.0 # change to latest version

2. Run from the command line:

$ pub get

Alternatively, your editor might support pub. Check the docs for your editor to learn more.

3. Import in your Dart code:

import 'package:validators/validators.dart';

Documentation

Validators

Sanitizers

Libraries

sanitizers
validators