vin-decoder-dart

Build Status Pub

A VIN decoding and validation library for Dart.

vin_decoder provides a simple decoding and validation library for Vehicle Identification Numbers (VINs) based on ISO 3779:2009 and World Manufacturer Identifiers (WMIs) based on ISO 3780:2009.

Usage

A simple usage example:

import 'package:vin_decoder/vin_decoder.dart';

main() {
  VIN vin = VIN(number: 'WP0ZZZ99ZTS392124');
  
   print('WMI: ${vin.wmi}');
   print('VDS: ${vin.vds}');
   print('VIS: ${vin.vis}');
  
   print("Model year is " + vin.modelYear());
   print("Serial number is " + vin.serialNumber());
   print("Assembly plant is " + vin.assemblyPlant());
   print("Manufacturer is " + vin.getManufacturer());
   print("Year is " + vin.getYear().toString());
   print("Region is " + vin.getRegion());
   print("VIN string is " + vin.toString());
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

License

Licensed under the terms of the Apache 2.0 license, the full version of which can be found in the LICENSE file included in the distribution.

Libraries

vin_decoder
Support for VIN parsing and validation.