weather_icons_flutter

Weather icons wrapper for Flutter.io

Dependency

In the dependencies: section of your pubspec.yaml, add the following line:

  weather_icons_flutter: ^1.0.0

Usage

import 'package:weather_icons_flutter/weather_icons_flutter.dart';

class MyWidget extends StatelessWidget {
  Widget build(BuildContext context) {
    return new IconButton(
      // Use the WeatherIcons class for the IconData
      icon: new Icon(WeatherIcons.stars),
      onPressed: () { print("Pressed"); }
     );
  }
}

Libraries

weather_icons_flutter