Babylon 0.0.3

  • Example
  • Installing
  • Versions
  • 24



  • Initial version, created by Stagehand


// Copyright (c) 2016, Cedware. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'package:Babylon/babylon.dart';
import 'dart:html';
import 'package:js/js.dart';

main() {
  CanvasElement canvas = querySelector("#canvas");
  Engine engine = new Engine(canvas,true);
  Scene scene = new Scene(engine);
  Camera camera = new FreeCamera("cam1", new Vector3(0.0,5.0,-10.0),scene);
  Light light = new HemisphericLight("light", new Vector3(0.0,1.0,0.0),scene);

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  Babylon: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:Babylon/babylon.dart';
import 'package:Babylon/engine.dart';
import 'package:Babylon/scene.dart';
import 'package:Babylon/vector3.dart';
Version Uploaded Documentation Archive
0.0.3 Jun 1, 2016 Go to the documentation of Babylon 0.0.3 Download Babylon 0.0.3 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 20, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.69.0
  • pana: 0.11.7


Detected platforms: web

Platform components identified in package: html, js.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Homepage does not exists.

We were unable to access at the time of the analysis.

Use constrained dependencies.

The pubspec.yaml contains 2 dependencies without version constraints. Specify version ranges for the following dependencies: browser, js.

Package is too old.

The package was released more than two years ago.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v1 release.

While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction of the API.

Format lib/babylon.dart.

Run dartfmt to format lib/babylon.dart.

Format lib/camera/camera.dart.

Run dartfmt to format lib/camera/camera.dart.

Fix additional 8 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/camera/free_camera.dart (Run dartfmt to format lib/camera/free_camera.dart.)
  • lib/engine.dart (Run dartfmt to format lib/engine.dart.)
  • lib/light/hermispheric_light.dart (Run dartfmt to format lib/light/hermispheric_light.dart.)
  • lib/light/light.dart (Run dartfmt to format lib/light/light.dart.)
  • lib/mesh/mesh.dart (Run dartfmt to format lib/mesh/mesh.dart.)
  • lib/mesh/spehere.dart (Run dartfmt to format lib/mesh/spehere.dart.)
  • lib/scene.dart (Run dartfmt to format lib/scene.dart.)
  • lib/vector3.dart (Run dartfmt to format lib/vector3.dart.)


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0
browser >=0.10.0+2 0.10.0+3
js >=0.6.0 0.6.1+1
Dev dependencies
test >=0.12.0 <0.13.0