Babylon 0.0.3

  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 0

Changelog

0.0.1

  • Initial version, created by Stagehand

example/main.dart

// Copyright (c) 2016, Cedware. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'package:Babylon/babylon.dart';
import 'dart:html';
import 'package:js/js.dart';

main() {
  print("lol");
  CanvasElement canvas = querySelector("#canvas");
  Engine engine = new Engine(canvas,true);
  Scene scene = new Scene(engine);
  Camera camera = new FreeCamera("cam1", new Vector3(0.0,5.0,-10.0),scene);
  camera.setTarget(Vector3.Zero());
  camera.attachControl(canvas,true);
  Mesh.createSphere("s1",30,1.0,scene);
  Light light = new HemisphericLight("light", new Vector3(0.0,1.0,0.0),scene);
  light.intensity=0.7;
  engine.runRenderLoop(allowInterop((){
    scene.render();
  }));
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  Babylon: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:Babylon/babylon.dart';
import 'package:Babylon/engine.dart';
import 'package:Babylon/scene.dart';
import 'package:Babylon/vector3.dart';
  
Version Uploaded Documentation Archive
0.0.3 Jun 1, 2016 Go to the documentation of Babylon 0.0.3 Download Babylon 0.0.3 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0