access 0.11.3

  • README.md
  • Installing
  • Versions
  • 82

Access

A simple database utility for the entity library.

Build Status

Use

access((DBAccess access) async {
  await for (final Row row in access.query('select ...')) {
    ...
  }
  ...
  await access.execute('update...');
})
//transactions ends here; roll back if an uncaught exception is thrown
.catchError((ex, st) {
  ...
});

Who Uses

  • Quire - a simple, collaborative, multi-level task management tool.

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  access: "^0.11.3"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:access/access.dart';
        
Version Uploaded Documentation Archive
0.11.3 Feb 9, 2018 Go to the documentation of access 0.11.3 Download access 0.11.3 archive
0.11.2 Jan 5, 2018 Go to the documentation of access 0.11.2 Download access 0.11.2 archive
0.11.1 Jan 5, 2018 Go to the documentation of access 0.11.1 Download access 0.11.1 archive
0.11.0 Sep 6, 2017 Go to the documentation of access 0.11.0 Download access 0.11.0 archive
0.10.1 Jun 2, 2017 Go to the documentation of access 0.10.1 Download access 0.10.1 archive
0.10.0 Apr 17, 2017 Go to the documentation of access 0.10.0 Download access 0.10.0 archive
0.9.10 Apr 10, 2017 Go to the documentation of access 0.9.10 Download access 0.9.10 archive
0.9.9 Mar 13, 2017 Go to the documentation of access 0.9.9 Download access 0.9.9 archive
0.9.8 Jan 24, 2017 Go to the documentation of access 0.9.8 Download access 0.9.8 archive
0.9.6 Dec 4, 2016 Go to the documentation of access 0.9.6 Download access 0.9.6 archive

All 56 versions...

Analysis

We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
74 / 100
Health:
Code health derived from static analysis. [more]
99 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
76 / 100
Overall score:
Weighted score of the above. [more]
82
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:access/access.dart.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Use constrained dependencies.

    The pubspec.yaml contains 4 dependencies without version constraints. Specify version ranges for the following dependencies: entity, logging, postgresql2, rikulo_commons.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use access.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 4 hints.

    Run dartfmt to format lib/access.dart.

    Run dartfmt to format lib/dbtool.dart.

    Similar analysis of the following files failed:

    • lib/src/dbtool/dbtool_create.dart (hint)
    • lib/src/dbtool/dbtool_purge.dart (hint)

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.21.0
entity >=0.7.0 0.9.3+4
logging any 0.11.3+1
postgresql2 any 0.3.4+4
rikulo_commons >=2.0.0 2.3.8+1
Transitive dependencies
charcode 1.1.1
collection 1.14.9
convert 2.0.1
crypto 2.0.2+1
func 0.1.1 1.0.0
mime 0.9.6
typed_data 1.1.5
Dev dependencies
test any