active_observers 0.5.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new68

active_observers #

Build Status

A new way to create composable UI logic, inspired by React hooks.

Getting Started #

import 'package:active_observers/active_observers.dart'; // 1.import package

class TestObserveState extends StatefulWidget {
  TestObserveState();

  @override
  _TestObserveStateState createState() => _TestObserveStateState();
}

class _TestObserveStateState extends State<TestObserveState>
    with ActiveObservers { // 2. Add a mixin to your State
  @override
  assembleActiveObservers() {
    state = observeState('a'); // 3. Setup active observers in constructor
  }

  ObserveState<String> state;

  @override
  Widget build(BuildContext context) {
    // 3. Get & set value. The widget will be automatically rebuilt.
    return Text(state.value, textDirection: TextDirection.ltr);
  }
}

Under construction.

Please refer to ./test/src for more active observers.

[0.0.1]

  • initial release

[0.1.0]

  • Add ActiveObserver interface

[0.1.1]

  • Add observeStream

[0.1.2]

  • Add observeListenable & observeValueListenableState

[0.2.0]

  • Add dependency update detection logic

[0.3.0]

  • Major rewrite
  • Remove dependencies other than Flutter
  • Active observers should be called in State's constructor

[0.3.1]

  • Make active observers run in the expected order

[0.3.2]

  • Always restart effect on reassemble

[0.3.3]

  • Add assembleActiveObservers slot

[0.3.4]

  • Clean active observers on reassemble
  • Now all active observers must be placed in assembleActiveObservers

[0.4.0]

  • Use implicit this in active observers

[0.4.1]

  • Mark assembleActiveObservers as virtual

[0.5.0]

  • Update observeLifecycle interface

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  active_observers: ^0.5.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:active_observers/active_observers.dart';
  
Version Uploaded Documentation Archive
0.5.0 Mar 20, 2019 Go to the documentation of active_observers 0.5.0 Download active_observers 0.5.0 archive
0.4.1 Mar 20, 2019 Go to the documentation of active_observers 0.4.1 Download active_observers 0.4.1 archive
0.4.0 Mar 17, 2019 Go to the documentation of active_observers 0.4.0 Download active_observers 0.4.0 archive
0.3.4 Mar 17, 2019 Go to the documentation of active_observers 0.3.4 Download active_observers 0.3.4 archive
0.3.3 Mar 16, 2019 Go to the documentation of active_observers 0.3.3 Download active_observers 0.3.3 archive
0.3.2 Mar 16, 2019 Go to the documentation of active_observers 0.3.2 Download active_observers 0.3.2 archive
0.3.1 Mar 16, 2019 Go to the documentation of active_observers 0.3.1 Download active_observers 0.3.1 archive
0.3.0 Mar 15, 2019 Go to the documentation of active_observers 0.3.0 Download active_observers 0.3.0 archive
0.2.0 Mar 10, 2019 Go to the documentation of active_observers 0.2.0 Download active_observers 0.2.0 archive
0.1.2 Mar 10, 2019 Go to the documentation of active_observers 0.1.2 Download active_observers 0.1.2 archive

All 13 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
41
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
68
Learn more about scoring.

We analyzed this package on Mar 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.3.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/active_observers.dart. (-0.50 points)

Analysis of lib/active_observers.dart reported 1 hint:

line 4 col 27: The library 'package:active_observers/src/active_observers.dart' doesn't export a member with the shown name 'ActiveObserver'.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and active_observers.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test