advanced_splashscreen 0.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 72

advanced_splashscreen #

Advanced splash screen

Screenshots #

Usage #

Example

To use this package :

  dependencies:
    flutter:
      sdk: flutter
    advanced_splashscreen:

How to use #

void main(){

  runApp(MaterialApp(
    home: AdvancedSplashScreen(
      child: ExampleApp(),
      seconds: 2,
      colorList: [
        Color(0xff9bcebb),
        Color(0xff9bceff),
        Color(0xff9bcfff),
      ],
      appIcon: "images/flutter_social.png",
    ),
  ));
}

class ExampleApp extends StatefulWidget {

  @override
  _ExampleAppState createState() => _ExampleAppState();
}

class _ExampleAppState extends State<ExampleApp> {

  @override
  Widget build(BuildContext context) {

    return Scaffold(
      body: Container(
        child: Center(
          child: Text("Splash Screen by https://marvey.io"),
        ),
      ),
    );
  }
}

License #

Copyright 2019 Apoorv Jain

Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at

   http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
See the License for the specific language governing permissions and
limitations under the License.

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

[0.0.1] - 20 March, 2019.

  • Animated customisable advanced splash screen written in dart.

example/example.dart

import 'package:flutter/material.dart';
import 'package:advanced_splashscreen/advanced_splashscreen.dart';

void main(){

  runApp(MaterialApp(
    home: AdvancedSplashScreen(
      child: ExampleApp(),
      seconds: 2,
      colorList: [
        Color(0xff9bcebb),
        Color(0xff9bceff),
        Color(0xff9bcfff),
      ],
      appIcon: "images/flutter_social.png",
    ),
  ));
}

class ExampleApp extends StatefulWidget {

  @override
  _ExampleAppState createState() => _ExampleAppState();
}

class _ExampleAppState extends State<ExampleApp> {

  @override
  Widget build(BuildContext context) {

    return Scaffold(
      body: Container(
        child: Center(
          child: Text("Flutter Social by ajax8732@gmail.com"),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  advanced_splashscreen: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:advanced_splashscreen/advanced_splashscreen.dart';
  
Version Uploaded Documentation Archive
0.0.1 Mar 20, 2019 Go to the documentation of advanced_splashscreen 0.0.1 Download advanced_splashscreen 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
55
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
72
Learn more about scoring.

We analyzed this package on Apr 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.4.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/advanced_splashscreen.dart.

Run flutter format to format lib/advanced_splashscreen.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test