aes_cbc 0.0.4

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

aes_cbc

A new flutter package project.

Getting Started

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  aes_cbc: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:aes_cbc/aes_cbc.dart';
  
Version Uploaded Documentation Archive
0.0.4 Aug 16, 2018 Go to the documentation of aes_cbc 0.0.4 Download aes_cbc 0.0.4 archive
0.0.3 Aug 16, 2018 Go to the documentation of aes_cbc 0.0.3 Download aes_cbc 0.0.3 archive
0.0.2 Aug 16, 2018 Go to the documentation of aes_cbc 0.0.2 Download aes_cbc 0.0.2 archive
0.0.1 Aug 16, 2018 Go to the documentation of aes_cbc 0.0.1 Download aes_cbc 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running flutter packages pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0-dev.9.3.flutter-9c07fb64c4.
 
 Because aes_cbc depends on bignum >=0.0.3 which requires SDK version <2.0.0, version solving failed.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use aes_cbc.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.63.0.flutter-4c9689c1d2 <3.0.0