A new flutter package project.
For help getting started with Flutter, view our online documentation.
For help on editing package code, view the documentation.
Add this to your package's pubspec.yaml file:
dependencies: aes_cbc: ^0.0.4
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
flutter packages get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.0.4||Aug 16, 2018|
|0.0.3||Aug 16, 2018|
|0.0.2||Aug 16, 2018|
|0.0.1||Aug 16, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Fix dependencies in
flutter packages pub upgrade failed with the following output:
ERR: The current Dart SDK version is 2.1.1-dev.0.1.flutter-ec86471ccc. Because aes_cbc depends on bignum >=0.0.3 which requires SDK version <2.0.0, version solving failed.
Fix platform conflicts. (-20 points)
Error(s) prevent platform classification:
Fix dependencies in
dartdoc failed. (-10 points)
dartdoc runs without any issues.
The description is too short. (-20 points)
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package. Common file name patterns include:
example.dart or you could also use
Package is pre-v0.1 release. (-10 points)
While there is nothing inherently wrong with versions of
0.0.*, it usually means that the author is still experimenting with the general direction of the API.
|Dart SDK||>=2.0.0-dev.63.0.flutter-4c9689c1d2 <3.0.0|