airkiss 1.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new44

dart-airkiss

pub package

A dart wechat airkiss lib to config IOT device.

Usage

To use this plugin, add airkiss as a dependency in your pubspec.yaml file.

dependencies:
  airkiss: ^1.0.0

Example

import 'package:airkiss/airkiss.dart';


import 'package:airkiss/airkiss.dart';

void test(String ssid, String pwd) async {
  print('config ssid:$ssid, pwd:$pwd');
  AirkissConfig ac = AirkissConfig();
  var res = await ac.config(ssid, pwd);
  if (res != null) {
    print('result: $res');
  }
  else {
    print(
        'config failed!!! please ensure phone/pc connected to Wi—Fi[$ssid] with 2.4GHz Channel(NOT 5GHz Channel)');
  }
}

void main() {
  test("SSID", "PASSWORD");
}

View on GitHub

1.0.0

  • First useable version.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  airkiss: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:airkiss/airkiss.dart';
  
Version Uploaded Documentation Archive
1.0.1 Jan 3, 2019 Go to the documentation of airkiss 1.0.1 Download airkiss 1.0.1 archive
1.0.0 Jan 3, 2019 Go to the documentation of airkiss 1.0.0 Download airkiss 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
44
Learn more about scoring.

We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.10

Platforms

Detected platforms: Flutter, other

Primary library: package:airkiss/airkiss.dart with components: io.

Health issues and suggestions

Document public APIs. (-1 points)

43 out of 43 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Format lib/airkiss.dart.

Run dartfmt to format lib/airkiss.dart.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use airkiss.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0