alpha2_countries 1.0.5

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new83

Alpha 2 countries

CircleCI Pub

ISO 3166-1 alpha-2 country codes for Dart. Based on alpha2-countries npm package by @slatkovic.

Usage

    final countries = Countries();
    final code = await countries.resolveCode('Estonia');
    final name = await countries.resolveName('EE');

1.0.5

  • Made API synchronous.

1.0.4

  • Made resolving case insensitive.

1.0.3

  • Inlined json data.

1.0.2

  • Using resources package to load countries.

1.0.1

  • Broadened the env restrictions to support Flutter.

1.0.0

  • Initial version with resolving by code and by name supported. Contains 249 countries.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  alpha2_countries: ^1.0.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:alpha2_countries/alpha2_countries.dart';
  
Version Uploaded Documentation Archive
1.0.5 Jul 31, 2018 Go to the documentation of alpha2_countries 1.0.5 Download alpha2_countries 1.0.5 archive
1.0.4 Jul 25, 2018 Go to the documentation of alpha2_countries 1.0.4 Download alpha2_countries 1.0.4 archive
1.0.3 Jul 25, 2018 Go to the documentation of alpha2_countries 1.0.3 Download alpha2_countries 1.0.3 archive
1.0.2 Jul 25, 2018 Go to the documentation of alpha2_countries 1.0.2 Download alpha2_countries 1.0.2 archive
1.0.1 Jul 25, 2018 Go to the documentation of alpha2_countries 1.0.1 Download alpha2_countries 1.0.1 archive
1.0.0 Jul 25, 2018 Go to the documentation of alpha2_countries 1.0.0 Download alpha2_countries 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
66
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
83
Learn more about scoring.

We analyzed this package on Aug 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.11.8

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:alpha2_countries/alpha2_countries.dart.

Suggestions

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use alpha2_countries.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
Dev dependencies
mockito any
test any