amap_location_plugin 0.2.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new50

Amap Location Plugin

pub package

A Flutter plugin to access location information with AMap Location SDK.

This plugin now is only developed for Android platform, so it only inplements the android amap sdk. which provides the function with location infomation for flutter app in android platform in china.

According to the usage description below, developer can get the location infomation easily.

Usage

To use this plugin, add amap_location_plugin as a dependency in your pubspec.yaml file.

1.依赖高德地图定位sdk

在app的build.gradle文件里加入

dependencies {
    implementation 'com.amap.api:location:latest.integration'
}

在flutter的pubspec.yaml文件里添加

dependencies:
  flutter:
    sdk: flutter

  ...
  amap_location_plugin: ^0.1.1

2.申请key

根据高德官方文档申请高德sdk的key

3.配置AndroidManifest.xml

在AndroidManifest.xml的application标签中配置Key:

<meta-data android:name="com.amap.api.v2.apikey" android:value="您的Key">
</meta-data>

在application标签中声明service组件:

<service android:name="com.amap.api.location.APSService"></service>

在AndroidManifest.xml中按需配置权限:

<!--用于进行网络定位-->
<uses-permission android:name="android.permission.ACCESS_COARSE_LOCATION"></uses-permission>
<!--用于访问GPS定位-->
<uses-permission android:name="android.permission.ACCESS_FINE_LOCATION"></uses-permission>
<!--获取运营商信息,用于支持提供运营商信息相关的接口-->
<uses-permission android:name="android.permission.ACCESS_NETWORK_STATE"></uses-permission>
<!--用于访问wifi网络信息,wifi信息会用于进行网络定位-->
<uses-permission android:name="android.permission.ACCESS_WIFI_STATE"></uses-permission>
<!--这个权限用于获取wifi的获取权限,wifi信息会用来进行网络定位-->
<uses-permission android:name="android.permission.CHANGE_WIFI_STATE"></uses-permission>
<!--用于访问网络,网络定位需要上网-->
<uses-permission android:name="android.permission.INTERNET"></uses-permission>
<!--用于读取手机当前的状态-->
<uses-permission android:name="android.permission.READ_PHONE_STATE"></uses-permission>
<!--写入扩展存储,向扩展卡写入数据,用于写入缓存定位数据-->
<uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE"></uses-permission>
<!--用于申请调用A-GPS模块-->
<uses-permission android:name="android.permission.ACCESS_LOCATION_EXTRA_COMMANDS"></uses-permission>
<!--用于申请获取蓝牙信息进行室内定位-->
<uses-permission android:name="android.permission.BLUETOOTH"></uses-permission>
<uses-permission android:name="android.permission.BLUETOOTH_ADMIN"></uses-permission>

Example

// Import package
import 'package:amap_location/amap_location_plugin.dart';

// Instantiate it
AmapLocation _amapLocation = AmapLocation();

//start location
_amapLocation.startLocation;

//stop location
_amapLocation.stopLocation;

// Access current location
print(_amapLocation.getLocation);

// Be informed when the state (full, charging, discharging) changes
_amapLocation.onLocationChanged.listen((String location) {
  // Do something with new state
});

0.0.1

  • initial release.

example/README.md

amap_location_example

Demonstrates how to use the amap_location plugin.

Getting Started

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  amap_location_plugin: ^0.2.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:amap_location_plugin/amap_location_plugin.dart';
  
Version Uploaded Documentation Archive
0.2.0 Nov 8, 2018 Go to the documentation of amap_location_plugin 0.2.0 Download amap_location_plugin 0.2.0 archive
0.1.1 Nov 1, 2018 Go to the documentation of amap_location_plugin 0.1.1 Download amap_location_plugin 0.1.1 archive
0.0.1 Oct 31, 2018 Go to the documentation of amap_location_plugin 0.0.1 Download amap_location_plugin 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
8
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Nov 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.6
  • Flutter: 0.11.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8