amaze_button 0.0.1

  • Example
  • Installing
  • Versions
  • 10


An amazing flutter package for amazing future buttons.


  • Initial release.


import 'dart:async';

import 'package:flutter/material.dart';
import 'package:amaze_button/amaze_button.dart';

void main() => runApp(new MyApp());

class MyApp extends StatelessWidget {
  Widget build(BuildContext context) {
    return new MaterialApp(
      title: 'Flutter Demo',
      theme: new ThemeData(
      home: new MyHomePage(),

class MyHomePage extends StatelessWidget {
  Widget build(BuildContext context) {
    return new Scaffold(
      appBar: new AppBar(
        title: new Text('Home Page'),
      body: new ListView(
        children: <Widget>[
          new FutureAmazeButton(
            child: new Container(
              child: new Text(
                'Some Text',
                style: new TextStyle(fontSize: 20.0),
              padding: new EdgeInsets.all(10.0),
              decoration: new BoxDecoration(
                  border: new Border.all(
                      width: 1.0,
                      style: BorderStyle.solid),
                      new BorderRadius.all(new Radius.circular(10.0))),
            futureCall: () {
              return new Future.delayed(Duration(seconds: 2));

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  amaze_button: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:amaze_button/amaze_button.dart';
Version Uploaded Documentation Archive
0.0.1 Aug 16, 2018 Go to the documentation of amaze_button 0.0.1 Download amaze_button 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Sep 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.12.3
  • Flutter: 0.8.4


Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Issues and suggestions

Fix platform conflicts.

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Fix dependencies in pubspec.yaml.

Running flutter packages pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0-dev.4.0.flutter-c28db2d6e1.
 Because amaze_button depends on test >=0.12.0-beta.3 <1.3.0 which requires SDK version >=1.8.0 <2.0.0-∞, version solving failed.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release.

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <3.0.0