analysis_server_client 1.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 6

Analysis Server Client

A client wrapper over Analysis Server. Instances of this client manages connection to Analysis Server and process and faciliates JSON protocol communication to and from the server.

Current implementation has no knowledge of the Analysis Server library yet. Future updates will allow for full class-access of Analysis Server protocol objects.

Analysis Server process must be instantiated separately and loaded into Analysis Server Client. To learn how to generate an Analysis Server Process, refer to the Analysis Server page.

#1.0.1

  • Update path on homepage

#1.0.0

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  analysis_server_client: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:analysis_server_client/analysis_server_client.dart';
  
Version Uploaded Documentation Archive
1.0.1 Aug 8, 2017 Go to the documentation of analysis_server_client 1.0.1 Download analysis_server_client 1.0.1 archive
1.0.0 Aug 8, 2017 Go to the documentation of analysis_server_client 1.0.0 Download analysis_server_client 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
11
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
6
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 < 2.0.0-dev.infinity