This package provides a low-level library that performs static analysis of Dart code. It is useful for tool integration and embedding.
End-users should use the dartanalyzer command-line tool to analyze their Dart code.
Integrators that want to add Dart support to their editor should use the Dart Analysis Server. The Analysis Server API Specification is available. If you are adding Dart support to an editor or IDE, please let us know by emailing our list.
dartanalyzer and Dart Analysis Server can be configured with an
analysis_options.yaml file (using an
.analysis_options file is deprecated).
This YAML file can control which files and paths are analyzed,
which lints are applied, and more.
If you are embedding the analyzer library in your project, you are responsible for finding the analysis options file, parsing it, and configuring the analyzer.
The analysis options file should live at the root of your project (for example,
next to your
pubspec.yaml). Different embedders of analyzer, such as
dartanalyzer or Dart Analysis Server, may choose to find the file in various
different ways. Consult their documentation to learn more.
Here is an example file that instructs the analyzer to ignore two files:
analyzer: exclude: - test/_data/p4/lib/lib1.dart - test/_data/p5/p5.dart - test/_data/bad*.dart - test/_brokendata/**
Note that you can use globs, as defined by the glob package.
Here is an example file that enables the analyzer's strong mode:
analyzer: strong-mode: true
Here is an example file that enables two lint rules:
linter: rules: - camel_case_types - empty_constructor_bodies
Check out all the available Dart lint rules.
You can combine the
analyzer section and the
linter section into a single
configuration. Here is an example:
analyzer: exclude: - test/_data/p4/lib/lib1.dart linter: rules: - camel_case_types
Many tools embed this library, such as:
Post issues and feature requests at https://github.com/dart-lang/sdk/issues
Questions and discussions are welcome at the Dart Analyzer Discussion Group.
The APIs in this package are, quite frankly, a mess at the moment. They were originally machine generated by a translator and were based on an earlier Java implementation. Several of the API's still look like their Java predecessors (or worse) rather than clean Dart API's.
In addition, there is currently no clean distinction between public and internal APIs. We plan to address this issue but doing so will, unfortunately, require a large number of breaking changes. We will try to minimize the pain this causes for our clients, but some pain is inevitable.
See the LICENSE file.
_InternalLinkedHashMapis not a subtype of
HashMapin sdk 2.0.0-dev.22.0.
NOTE This release was pulled from the package site due to an invalid SDK
constraint that was fixed in
A number of updates, including support for the new Function syntax.
nullin the event that the given path is not part of a BazelWorkspace.
astFactory, located in
_embedder.yamldiscovery and processing.
configureContext()extracted from server).
AnalysisContextAPI for associating configuration data with contexts (
OptionsProcessorextension point API changed to pass associated
AnalysisContextinstance into the
ErrorHandlertypedef API fix.
.packagesfiles (issue 24126)
UriResolver.resolveUri(..)now takes an optional
ResolutionCopier.visitAwaitExpressionto copy *Type fields.
ClassName?.staticMemberto match spec.
UriResolver.resolveUri(..)that did not properly handle the new
_sdkext(to play nicer with pub).
analyzer_clipackage. Files moved:
DartSdk.fromEncoding replaced with
Source.resolveRelative replaced with
Add this to your package's pubspec.yaml file:
dependencies: analyzer: "^0.31.1"
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.31.1||Feb 9, 2018|
|0.31.0+1||Feb 2, 2018|
|0.30.0+4||Sep 21, 2017|
|0.30.0+3||Sep 21, 2017|
|0.30.0+2||May 21, 2017|
|0.30.0+1||May 21, 2017|
|0.30.0||May 3, 2017|
|0.29.11||May 2, 2017|
|0.29.10||Mar 30, 2017|
|0.29.9||Mar 24, 2017|
We analyzed this package on Apr 9, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Detected platforms: Flutter, other
Fix analysis and formatting issues.
Analysis or formatting checks reported 125 hints.
Strong-mode analysis of
lib/dart/element/element.dartgave the following hint:
line: 1013 col: 11
Strong-mode analysis of
lib/file_system/memory_file_system.dartgave the following hint:
line: 137 col: 26
'UTF8' is deprecated and shouldn't be used.
Similar analysis of the following files failed:
The description is too short.
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Package is pre-v1 release.
While there is nothing inherently wrong with versions of
0.*.*, it usually means that the author is still experimenting with the general direction API.
Maintain an example.
None of the files in your
example/directory matches a known example patterns. Common file name patterns include:
example.dartor you could also use
|Dart SDK||>=2.0.0-dev <2.0.0|