analyzer_plugin 0.0.1-alpha.0

  • Installing
  • Versions
  • 70


A framework for building plugins for the analysis server.


Note: The plugin support is not currently available for general use.

Plugins are written in Dart and are run in the same VM as the analysis server. The analysis server runs each plugin in a separate isolate and communicates with the plugin using a plugin API. This API is similar to the API used by the analysis server to communicate with clients.

Plugins are automatically discovered and run by the analysis server.

This package contains support code to make it easier to write a plugin. There is a tutorial describing how to use the support in this package.


Post issues and feature requests on the issue tracker.

Questions and discussions are welcome at the Dart Analyzer Discussion Group.


See the LICENSE file.



  • Initial version

1. Depend on it

Add this to your package's pubspec.yaml file:

  analyzer_plugin: "^0.0.1-alpha.0"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:analyzer_plugin/starter.dart';
Version Uploaded Documentation Archive
0.0.1-alpha.0 Aug 25, 2017 Go to the documentation of analyzer_plugin 0.0.1-alpha.0 Download analyzer_plugin 0.0.1-alpha.0 archive


This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • completed on Feb 3, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1


Describes how popular the package is relative to other packages. [more]
67 / 100
Code health derived from static analysis. [more]
57 / 100
Reflects how tidy and up-to-date the package is. [more]
98 / 100
Overall score:
Weighted score of the above. [more]


Detected platforms: Flutter, other

Platform components identified in package: io.


  • Package is pre-release.

    Pre-release versions should be used with caution, their API may change in breaking ways.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use analyzer_plugin.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0
analyzer ^0.31.0-alpha.1 0.31.0+1
charcode ^1.1.0 1.1.1
html ^0.13.1 0.13.2+2
path ^1.4.1 1.5.1
pub_semver ^1.3.2 1.3.2
Transitive dependencies
args 1.3.0
async 2.0.3
cli_util 0.1.2+1
collection 1.14.5
convert 2.0.1
crypto 2.0.2+1
csslib 0.14.1
front_end 0.1.0-alpha.8
glob 1.1.5
isolate 1.1.0
kernel 0.3.0-alpha.5
logging 0.11.3+1
meta 1.1.2
package_config 1.0.3
plugin 0.2.0+2
source_span 1.4.0
string_scanner 1.0.2
typed_data 1.1.5
utf 0.9.0+4
watcher 0.9.7+7
yaml 2.1.13
Dev dependencies
test ^0.12.17
test_reflective_loader ^0.1.0