angel 2.0.0

  • README.md
  • Installing
  • Versions
  • 58

Logo

This is a discontinued legacy entrypoint. Head to the Angel site instead.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angel: ^2.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

Version Uploaded Documentation Archive
2.0.0 Nov 2, 2018 Go to the documentation of angel 2.0.0 Download angel 2.0.0 archive
1.0.0-dev Jul 5, 2016 Go to the documentation of angel 1.0.0-dev Download angel 1.0.0-dev archive
1.0.0-alpha Dec 21, 2016 Go to the documentation of angel 1.0.0-alpha Download angel 1.0.0-alpha archive
0.0.0-dev.0 Apr 22, 2016 Go to the documentation of angel 0.0.0-dev.0 Download angel 0.0.0-dev.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
28
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
58
Learn more about scoring.

We analyzed this package on Feb 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13+1

Platforms

Detected platforms: Flutter, web, other

No libraries.

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and angel.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.10 <3.0.0