angel_auth_instagram 1.0.0

  • Installing
  • Versions
  • 0


angel_auth strategy for Instagram OAuth2 login.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  angel_auth_instagram: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:angel_auth_instagram/angel_auth_instagram.dart';
Version Uploaded Documentation Archive
1.0.0 Jul 18, 2017 Go to the documentation of angel_auth_instagram 1.0.0 Download angel_auth_instagram 1.0.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 Because instagram <=1.0.0-rc.1 requires SDK version >=1.19.0 <2.0.0 and instagram >=1.0.0 depends on owl ^0.2.1, every version of instagram requires owl ^0.2.1.
 And because owl >=0.1.1 <0.2.3 requires SDK version >=1.20.0 <2.0.0 and owl >=0.2.3 <0.4.0 depends on postgresql ^0.3.4, every version of instagram requires postgresql ^0.3.4.
 So, because postgresql >=0.2.1 requires SDK version <2.0.0 and angel_auth_instagram depends on instagram ^1.0.0-beta, version solving failed.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Maintain (-20 points)

Changelog entries help clients to follow the progress in your code.

Package is getting outdated. (-39.73 points)

The package was released 72 weeks ago.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use angel_auth_instagram.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0