angel_auth_twitter 1.0.0

  • Installing
  • Versions
  • 0


angel_auth strategy for Twitter login.

See the example;

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  angel_auth_twitter: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:angel_auth_twitter/angel_auth_twitter.dart';
Version Uploaded Documentation Archive
1.0.2 Mar 17, 2017 Go to the documentation of angel_auth_twitter 1.0.2 Download angel_auth_twitter 1.0.2 archive
1.0.1 Feb 25, 2017 Go to the documentation of angel_auth_twitter 1.0.1 Download angel_auth_twitter 1.0.1 archive
1.0.0 Dec 23, 2016 Go to the documentation of angel_auth_twitter 1.0.0 Download angel_auth_twitter 1.0.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

This package version is not analyzed, because it is more than two years old. Check the latest stable version for its analysis.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 Because angel_auth <1.1.1 requires SDK version <2.0.0 and angel_auth >=1.1.1 <2.0.0-alpha depends on angel_framework ^1.1.0-alpha, angel_auth <2.0.0-alpha requires angel_framework ^1.1.0-alpha.
 And because angel_framework >=0.0.0-dev.1 <1.1.3 requires SDK version <2.0.0 and angel_framework >=1.1.3 <2.0.0-alpha depends on container ^0.1.2, angel_auth <2.0.0-alpha requires container ^0.1.2.
 So, because container >=0.1.1 requires SDK version >=1.8.0 <2.0.0 and angel_auth_twitter depends on angel_auth ^1.0.0-dev, version solving failed.

Health suggestions

Format lib/angel_auth_twitter.dart.

Run dartfmt to format lib/angel_auth_twitter.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Maintain (-20 points)

Changelog entries help clients to follow the progress in your code.

Package is getting outdated. (-99.73 points)

The package was released 104 weeks ago.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use angel_auth_twitter.dart. Packages with multiple examples should use example/


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0