angel_cli 1.3.4

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 46

angel_cli

Screenshot of Terminal

Command-line tools for the Angel framework. Includes functionality such as:

  • Project scaffolding
  • Generating service models, plugins, tests and more
  • Renaming projects
  • Much more...

To install:

$ pub global activate angel_cli

And then, for information on each command:

$ angel help

1.3.4

  • Fix another typo.

1.3.3

  • Fix a small typo in the model generator.

1.3.2

  • Restore part directives in generated models.

1.3.1

  • Add deploy nginx and deploy systemd.

1.3.0

  • Focus on Dart2 from here on out.
  • Update code_builder.
  • More changes...

1.1.5

Deprecated several commands, in favor of the make command:

  • controller
  • plugin
  • service
  • test

The rename command will now replace all occurrences of the old project names with the new one in config/ YAML files, and also operates on the glob config/**/*.yaml.

Changed the call to run angel start to run dart bin/server.dart instead, after an init command.

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate angel_cli

2. Use it

The package has the following executables:


$ angel

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angel_cli: ^1.3.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angel_cli/angel_cli.dart';
  
Version Uploaded Documentation Archive
1.3.4 Jul 15, 2018 Go to the documentation of angel_cli 1.3.4 Download angel_cli 1.3.4 archive
1.3.3 Jul 15, 2018 Go to the documentation of angel_cli 1.3.3 Download angel_cli 1.3.3 archive
1.3.2 Jul 15, 2018 Go to the documentation of angel_cli 1.3.2 Download angel_cli 1.3.2 archive
1.3.1 Jul 15, 2018 Go to the documentation of angel_cli 1.3.1 Download angel_cli 1.3.1 archive
1.3.0 Jul 14, 2018 Go to the documentation of angel_cli 1.3.0 Download angel_cli 1.3.0 archive
1.2.0+5 Oct 20, 2017 Go to the documentation of angel_cli 1.2.0+5 Download angel_cli 1.2.0+5 archive
1.2.0+4 Oct 20, 2017 Go to the documentation of angel_cli 1.2.0+4 Download angel_cli 1.2.0+4 archive
1.2.0+3 Oct 20, 2017 Go to the documentation of angel_cli 1.2.0+3 Download angel_cli 1.2.0+3 archive
1.2.0+2 Oct 20, 2017 Go to the documentation of angel_cli 1.2.0+2 Download angel_cli 1.2.0+2 archive
1.2.0+1 Oct 20, 2017 Go to the documentation of angel_cli 1.2.0+1 Download angel_cli 1.2.0+1 archive

All 53 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Aug 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.11.8

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because angel_cli depends on homedir any which requires SDK version >=1.13.0 <2.0.0, version solving failed.

Fix platform conflicts.

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use angel_cli.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev <3.0.0