angel_common 1.0.0

  • Installing
  • Versions
  • 25


The Angel Framework

Gitter version: v1.0.0

Master package to install the current Angel framework. This package installs and exposes the Angel server framework, as well as the following plugins that make up the rest of the Angel application framework:

This package will also install the following, although it does not expose them:

route is exposed by framework, although it is not a plugin.

Every library included is well-documented. Happy coding!

import 'package:angel_common/angel_common.dart';

main() async {
    var app = new Angel();

    // ...

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  angel_common: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:angel_common/angel_common.dart';
Version Uploaded Documentation Archive
1.0.0 Apr 10, 2017 Go to the documentation of angel_common 1.0.0 Download angel_common 1.0.0 archive
1.0.0-beta Feb 1, 2017 Go to the documentation of angel_common 1.0.0-beta Download angel_common 1.0.0-beta archive
1.0.0-alpha+1 Dec 27, 2016 Go to the documentation of angel_common 1.0.0-alpha+1 Download angel_common 1.0.0-alpha+1 archive
1.0.0-alpha Dec 21, 2016 Go to the documentation of angel_common 1.0.0-alpha Download angel_common 1.0.0-alpha archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Dec 9, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7


Detected platforms:

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 Because angel_common depends on angel_relations >=1.0.0 which requires SDK version >=1.19.0 <2.0.0, version solving failed.

Health suggestions

Format lib/angel_common.dart.

Run dartfmt to format lib/angel_common.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Maintain (-20 points)

Changelog entries help clients to follow the progress in your code.

Package is getting outdated. (-66.58 points)

The package was released 86 weeks ago.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use angel_common.dart. Packages with multiple examples should use example/


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0