angel_common 1.0.0

  • README.md
  • Installing
  • Versions
  • 31

common #

The Angel Framework

Gitter version: v1.0.0

Master package to install the current Angel framework. This package installs and exposes the Angel server framework, as well as the following plugins that make up the rest of the Angel application framework:

This package will also install the following, although it does not expose them:

route is exposed by framework, although it is not a plugin.

Every library included is well-documented. Happy coding!

import 'package:angel_common/angel_common.dart';

main() async {
    var app = new Angel();

    // ...
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angel_common: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angel_common/angel_common.dart';
  
Version Uploaded Documentation Archive
1.0.0 Apr 10, 2017 Go to the documentation of angel_common 1.0.0 Download angel_common 1.0.0 archive
1.0.0-beta Feb 1, 2017 Go to the documentation of angel_common 1.0.0-beta Download angel_common 1.0.0-beta archive
1.0.0-alpha+1 Dec 27, 2016 Go to the documentation of angel_common 1.0.0-alpha+1 Download angel_common 1.0.0-alpha+1 archive
1.0.0-alpha Dec 21, 2016 Go to the documentation of angel_common 1.0.0-alpha Download angel_common 1.0.0-alpha archive
Popularity:
Describes how popular the package is relative to other packages. [more]
61
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
31
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0