angel_compiled_mustache 1.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

angel_compiled_mustache

Travis Pub

This is an Angel wrapper for the lightweight compiled_mustache render engine.

Changelog

1.1.0

  • Switch from using dart:io to package:file
  • Remove support for Dart sdk <1.8.0

1.0.1

  • Clean up documentation and the main function

1.0.0

  • Initial release

1.0.0-pre

  • Stage initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angel_compiled_mustache: ^1.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angel_compiled_mustache/angel_compiled_mustache.dart';
  
Version Uploaded Documentation Archive
1.1.0 Dec 11, 2017 Go to the documentation of angel_compiled_mustache 1.1.0 Download angel_compiled_mustache 1.1.0 archive
1.0.1 Dec 2, 2017 Go to the documentation of angel_compiled_mustache 1.0.1 Download angel_compiled_mustache 1.0.1 archive
1.0.0 Dec 2, 2017 Go to the documentation of angel_compiled_mustache 1.0.0 Download angel_compiled_mustache 1.0.0 archive
1.0.0-pre Dec 2, 2017 Go to the documentation of angel_compiled_mustache 1.0.0-pre Download angel_compiled_mustache 1.0.0-pre archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0