angel_compress 1.0.0+2

  • README.md
  • Installing
  • Versions
  • 7

compress

version 1.0.0+2 build status

Angel hook to compress responses in a variety of formats.

import 'package:angel_framework/angel_framework.dart';
import 'package:angel_compress/angel_compress.dart';
import 'package:lzw/lzw.dart';

main() {
  var app = new Angel();
  
  // GZIP is the easiest to add
  app.responseFinalizers.add(gzip());
  
  // Support any other codec
  app.responseFinalizers.add(compress('lzw', LZW));
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angel_compress: ^1.0.0+2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angel_compress/angel_compress.dart';
  
Version Uploaded Documentation Archive
1.0.0+2 Jan 14, 2017 Go to the documentation of angel_compress 1.0.0+2 Download angel_compress 1.0.0+2 archive
1.0.0+1 Jan 14, 2017 Go to the documentation of angel_compress 1.0.0+1 Download angel_compress 1.0.0+1 archive
1.0.0 Dec 21, 2016 Go to the documentation of angel_compress 1.0.0 Download angel_compress 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
14
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
7
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 
 Because angel_framework >=0.0.0-dev.1 <1.1.3 requires SDK version <2.0.0 and angel_framework >=1.1.3 <2.0.0-alpha depends on container ^0.1.2, angel_framework >=0.0.0-dev.1 <2.0.0-alpha requires container ^0.1.2.
 So, because container >=0.1.1 requires SDK version >=1.8.0 <2.0.0 and angel_compress depends on angel_framework ^1.0.0-dev.34, version solving failed.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

Package is getting outdated. (-90.41 points)

The package was released 99 weeks ago.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use angel_compress.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0