angel_compress 1.0.0+2

  • Installing
  • Versions
  • 58


version 1.0.0+2 build status

Angel hook to compress responses in a variety of formats.

import 'package:angel_framework/angel_framework.dart';
import 'package:angel_compress/angel_compress.dart';
import 'package:lzw/lzw.dart';

main() {
  var app = new Angel();
  // GZIP is the easiest to add
  // Support any other codec
  app.responseFinalizers.add(compress('lzw', LZW));

1. Depend on it

Add this to your package's pubspec.yaml file:

  angel_compress: "^1.0.0+2"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:angel_compress/angel_compress.dart';
Version Uploaded Documentation Archive
1.0.0+2 Jan 14, 2017 Go to the documentation of angel_compress 1.0.0+2 Download angel_compress 1.0.0+2 archive
1.0.0+1 Jan 14, 2017 Go to the documentation of angel_compress 1.0.0+1 Download angel_compress 1.0.0+1 archive
1.0.0 Dec 21, 2016 Go to the documentation of angel_compress 1.0.0 Download angel_compress 1.0.0 archive


This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • completed on Feb 3, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1


Describes how popular the package is relative to other packages. [more]
26 / 100
Code health derived from static analysis. [more]
100 / 100
Reflects how tidy and up-to-date the package is. [more]
76 / 100
Overall score:
Weighted score of the above. [more]


Detected platforms: other

Primary library: package:angel_compress/angel_compress.dart with components: io, mirrors.


  • Maintain

    Changelog entries help clients to follow the progress in your code.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use angel_compress.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0
angel_framework ^1.0.0-dev.34 1.1.0+3
Transitive dependencies
angel_http_exception 1.0.0
angel_model 1.0.0
angel_route 2.0.5
async 2.0.3
body_parser 1.0.3
charcode 1.1.1
collection 1.14.5
combinator 1.0.0-beta+7
container 0.1.2
http_server 0.9.7
json_god 2.0.0-beta+1
logging 0.11.3+1
matcher 0.12.1+4
merge_map 1.0.0
meta 1.1.2
mime 0.9.6
path 1.5.1
pool 1.3.4
quiver_hashcode 1.0.0
random_string 0.0.1
source_span 1.4.0
stack_trace 1.9.1
string_scanner 1.0.2
tuple 1.0.1
Dev dependencies
lzw ^0.1.0
test ^0.12.18