angel_cors 1.0.0+2

  • README.md
  • Installing
  • Versions
  • 82

cors

1.0.0+1 build status

Angel CORS middleware. Port of the original Express CORS middleware.

main() {
    var app = new Angel();
    app.before.add(cors());
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angel_cors: ^1.0.0+2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angel_cors/angel_cors.dart';
  
Version Uploaded Documentation Archive
1.0.0+2 Nov 18, 2017 Go to the documentation of angel_cors 1.0.0+2 Download angel_cors 1.0.0+2 archive
1.0.0+1 Apr 15, 2017 Go to the documentation of angel_cors 1.0.0+1 Download angel_cors 1.0.0+1 archive
1.0.0 Apr 10, 2017 Go to the documentation of angel_cors 1.0.0 Download angel_cors 1.0.0 archive
1.0.0-dev+2 Dec 21, 2016 Go to the documentation of angel_cors 1.0.0-dev+2 Download angel_cors 1.0.0-dev+2 archive
1.0.0-dev+1 Dec 5, 2016 Go to the documentation of angel_cors 1.0.0-dev+1 Download angel_cors 1.0.0-dev+1 archive
1.0.0-dev Dec 5, 2016 Go to the documentation of angel_cors 1.0.0-dev Download angel_cors 1.0.0-dev archive
Popularity:
Describes how popular the package is relative to other packages. [more]
79
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
64
Overall:
Weighted score of the above. [more]
82
Learn more about scoring.

We analyzed this package on Aug 13, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.11.8

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because angel_framework >=0.0.0-dev.1 <1.1.3 requires SDK version <2.0.0 and angel_framework >=1.1.3 depends on random_string ^0.0.1, angel_framework >=0.0.0-dev.1 requires random_string ^0.0.1.
 So, because every version of random_string requires SDK version >=1.0.0 <2.0.0 and angel_cors depends on angel_framework ^1.0.0-dev, version solving failed.

Fix platform conflicts.

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Maintain CHANGELOG.md.

Changelog entries help clients to follow the progress in your code.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use angel_cors.dart.

Format lib/src/cors_options.dart.

Run dartfmt to format lib/src/cors_options.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0