angel_errors 1.1.0

  • Installing
  • Versions
  • 2


build status

Error handling plugin for Angel.

See the tests for examples.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  angel_errors: ^1.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:angel_errors/angel_errors.dart';
Version Uploaded Documentation Archive
1.1.0 Nov 18, 2017 Go to the documentation of angel_errors 1.1.0 Download angel_errors 1.1.0 archive
1.0.0 Apr 10, 2017 Go to the documentation of angel_errors 1.0.0 Download angel_errors 1.0.0 archive
1.0.0-dev+2 Dec 21, 2016 Go to the documentation of angel_errors 1.0.0-dev+2 Download angel_errors 1.0.0-dev+2 archive
1.0.0-dev+1 Dec 21, 2016 Go to the documentation of angel_errors 1.0.0-dev+1 Download angel_errors 1.0.0-dev+1 archive
1.0.0-dev Dec 11, 2016 Go to the documentation of angel_errors 1.0.0-dev Download angel_errors 1.0.0-dev archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 Because angel_errors depends on angel_framework >=0.0.0-dev.1 <1.1.3 which requires SDK version <2.0.0, version solving failed.

Health suggestions

Format lib/angel_errors.dart.

Run dartfmt to format lib/angel_errors.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Maintain (-20 points)

Changelog entries help clients to follow the progress in your code.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use angel_errors.dart.

Package is getting outdated. (-7.67 points)

The package was released 56 weeks ago.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0