angel_migration 1.0.0-alpha+3

  • Installing
  • Versions
  • 1

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angel_migration: ^1.0.0-alpha+3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angel_migration/angel_migration.dart';
  
Version Uploaded Documentation Archive
1.0.0-alpha+3 Nov 23, 2017 Go to the documentation of angel_migration 1.0.0-alpha+3 Download angel_migration 1.0.0-alpha+3 archive
1.0.0-alpha+2 Nov 18, 2017 Go to the documentation of angel_migration 1.0.0-alpha+2 Download angel_migration 1.0.0-alpha+2 archive
1.0.0-alpha+1 Oct 21, 2017 Go to the documentation of angel_migration 1.0.0-alpha+1 Download angel_migration 1.0.0-alpha+1 archive
1.0.0-alpha Aug 3, 2017 Go to the documentation of angel_migration 1.0.0-alpha Download angel_migration 1.0.0-alpha archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
5
Overall:
Weighted score of the above. [more]
1
Learn more about scoring.

We analyzed this package on Oct 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.12.4

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because angel_migration depends on angel_orm <2.0.0-dev.1 which requires SDK version >=1.19.0 <2.0.0 or >=2.0.0-dev.1.2 <2.0.0, version solving failed.

Health suggestions

Format lib/angel_migration.dart.

Run dartfmt to format lib/angel_migration.dart.

Format lib/src/column.dart.

Run dartfmt to format lib/src/column.dart.

Format lib/src/migration.dart.

Run dartfmt to format lib/src/migration.dart.

Format lib/src/table.dart.

Run dartfmt to format lib/src/table.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Maintain README.md. (-30 points)

Readme should inform others about your project, what it does, and how they can use it.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-release. (-5 points)

Pre-release versions should be used with caution, their API may change in breaking ways.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use angel_migration.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0