angel_migration_runner 1.0.0-alpha+6

  • CHANGELOG.md
  • Installing
  • Versions
  • 60

1.0.0-alpha+5

Schema#drop now has a named cascade parameter, of type bool.

1.0.0-alpha+1

  • You can now pass a connected parameter.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angel_migration_runner: ^1.0.0-alpha+6

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angel_migration_runner/angel_migration_runner.dart';
  
Version Uploaded Documentation Archive
1.0.0-alpha+6 Nov 23, 2017 Go to the documentation of angel_migration_runner 1.0.0-alpha+6 Download angel_migration_runner 1.0.0-alpha+6 archive
1.0.0-alpha+5 Oct 21, 2017 Go to the documentation of angel_migration_runner 1.0.0-alpha+5 Download angel_migration_runner 1.0.0-alpha+5 archive
1.0.0-alpha+4 Oct 21, 2017 Go to the documentation of angel_migration_runner 1.0.0-alpha+4 Download angel_migration_runner 1.0.0-alpha+4 archive
1.0.0-alpha+3 Oct 21, 2017 Go to the documentation of angel_migration_runner 1.0.0-alpha+3 Download angel_migration_runner 1.0.0-alpha+3 archive
1.0.0-alpha+2 Aug 4, 2017 Go to the documentation of angel_migration_runner 1.0.0-alpha+2 Download angel_migration_runner 1.0.0-alpha+2 archive
1.0.0-alpha+1 Aug 4, 2017 Go to the documentation of angel_migration_runner 1.0.0-alpha+1 Download angel_migration_runner 1.0.0-alpha+1 archive
1.0.0-alpha Aug 3, 2017 Go to the documentation of angel_migration_runner 1.0.0-alpha Download angel_migration_runner 1.0.0-alpha archive
Popularity:
Describes how popular the package is relative to other packages. [more]
31
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
74
Overall:
Weighted score of the above. [more]
60
Learn more about scoring.

We analyzed this package on Aug 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.11.8

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because angel_migration_runner depends on angel_migration any which requires SDK version >=1.19.0 <2.0.0, version solving failed.

Fix platform conflicts.

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Maintain README.md.

Readme should inform others about your project, what it does, and how they can use it.

Package is pre-release.

Pre-release versions should be used with caution, their API may change in breaking ways.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Format lib/angel_migration_runner.dart.

Run dartfmt to format lib/angel_migration_runner.dart.

Format lib/postgres.dart.

Run dartfmt to format lib/postgres.dart.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use angel_migration_runner.dart.

Fix additional 4 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/postgres/schema.dart (Run dartfmt to format lib/src/postgres/schema.dart.)
  • lib/src/postgres/table.dart (Run dartfmt to format lib/src/postgres/table.dart.)
  • lib/src/runner.dart (Run dartfmt to format lib/src/runner.dart.)
  • lib/src/util.dart (Run dartfmt to format lib/src/util.dart.)

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0