angel_model 1.0.2

  • Example
  • Installing
  • Versions
  • 86

angel_model #

Angel's basic data model class, no longer with the added weight of the whole framework.

import 'package:angel_model/angel_model.dart';

This package was created to prevent dependency collisions with third-party packages.

1.0.2 #

  • idAsInt now uses int.tryParse.

1.0.1 #

  • Add idAsInt.

1.0.0+1 #

  • Update constraint to work with Dart 2.


import 'package:angel_model/angel_model.dart';

void main() {
  var todo = Todo(id: '34', isComplete: false);
  print(todo.idAsInt == 34);

class Todo extends Model {
  String text;

  bool isComplete;

      {String id,
      DateTime createdAt,
      DateTime updatedAt})
      : super(id: id, createdAt: createdAt, updatedAt: updatedAt);

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  angel_model: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:angel_model/angel_model.dart';
Version Uploaded Documentation Archive
1.0.2 Mar 29, 2019 Go to the documentation of angel_model 1.0.2 Download angel_model 1.0.2 archive
1.0.1 Dec 31, 2018 Go to the documentation of angel_model 1.0.1 Download angel_model 1.0.1 archive
1.0.0+1 Aug 19, 2018 Go to the documentation of angel_model 1.0.0+1 Download angel_model 1.0.0+1 archive
1.0.0 Jul 11, 2017 Go to the documentation of angel_model 1.0.0 Download angel_model 1.0.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Apr 4, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:angel_model/angel_model.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <3.0.0
Dev dependencies
pedantic ^1.0.0