angel_oauth2 2.0.0

  • Installing
  • Versions
  • 51


Pub build status

A class containing handlers that can be used within Angel to build a spec-compliant OAuth 2.0 server.


In your pubspec.yaml:

  angel_oauth2: ^1.0.0


Your server needs to have definitions of at least two types:

  • One model that represents a third-party application (client) trying to access a user's profile.
  • One that represents a user logged into the application.

Define a server class as such:

import 'package:angel_oauth2/angel_oauth2.dart' as oauth2;

class MyServer extends oauth2.AuthorizationServer<Client, User> {}

Then, implement the findClient and verifyClient to ensure that the server class can not only identify a client application via a client_id, but that it can also verify its identity via a client_secret.

class _Server extends AuthorizationServer<PseudoApplication, Map> {
  final Uuid _uuid = new Uuid();

  FutureOr<PseudoApplication> findClient(String clientId) {
    return clientId == ? pseudoApplication : null;

  Future<bool> verifyClient(
      PseudoApplication client, String clientSecret) async {
    return client.secret == clientSecret;

Next, write some logic to be executed whenever a user visits the authorization endpoint. In most cases, you will want to show a dialog:

Future requestAuthorizationCode(
  PseudoApplication client,
  String redirectUri,
  Iterable<String> scopes,
  String state,
  RequestContext req,
  ResponseContext res) async {

Now, write logic that exchanges an authorization code for an access token, and optionally, a refresh token.

Future<AuthorizationCodeResponse> exchangeAuthCodeForAccessToken(
  String authCode,
  String redirectUri,
  RequestContext req,
  ResponseContext res) async {
    return new AuthorizationCodeResponse('foo', refreshToken: 'bar');

Now, set up some routes to point the server.

void pseudoCode() {'/oauth2', (router) {
      ..get('/authorize', server.authorizationEndpoint)'/token', server.tokenEndpoint);

The authorizationEndpoint and tokenEndpoint handle all OAuth2 grant types.

Other Grants

By default, all OAuth2 grant methods will throw a 405 Method Not Allowed error. To support any specific grant type, all you need to do is implement the method. The following are available, not including authorization code grant support (mentioned above):

  • implicitGrant
  • resourceOwnerPasswordCredentialsGrant
  • clientCredentialsGrant

Read the OAuth2 specification for in-depth information on each grant type.


  • Angel 2 support.


  • Dart2 updates + backwards compatibility assurance.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  angel_oauth2: ^2.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:angel_oauth2/angel_oauth2.dart';
Version Uploaded Documentation Archive
2.0.0 Nov 8, 2018 Go to the documentation of angel_oauth2 2.0.0 Download angel_oauth2 2.0.0 archive
1.0.0+1 Jul 9, 2018 Go to the documentation of angel_oauth2 1.0.0+1 Download angel_oauth2 1.0.0+1 archive
1.0.0 Dec 7, 2017 Go to the documentation of angel_oauth2 1.0.0 Download angel_oauth2 1.0.0 archive
1.0.0-alpha+1 Oct 16, 2017 Go to the documentation of angel_oauth2 1.0.0-alpha+1 Download angel_oauth2 1.0.0-alpha+1 archive
1.0.0-alpha Oct 16, 2017 Go to the documentation of angel_oauth2 1.0.0-alpha Download angel_oauth2 1.0.0-alpha archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7


Detected platforms: Flutter, other

Primary library: package:angel_oauth2/angel_oauth2.dart with components: io.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use angel_oauth2.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev <3.0.0
angel_framework ^2.0.0-alpha 2.0.0-alpha.14
angel_http_exception ^1.0.0 1.0.0+3
Transitive dependencies
angel_container 1.0.0
angel_model 1.0.0+1
angel_route 3.0.0
body_parser 1.1.1
charcode 1.1.2
code_buffer 1.0.1
collection 1.14.11
combinator 1.0.0+3
convert 2.0.2
crypto 2.0.6
dart2_constant 1.0.2+dart2
file 5.0.6
http2 0.1.9
http_parser 3.1.3
http_server 0.9.8+1
intl 0.15.7
matcher 0.12.4
merge_map 1.0.1
meta 1.1.6
mime 0.9.6+2
mock_request 1.0.4
path 1.6.2
quiver 2.0.1
source_span 1.4.1
stack_trace 1.9.3
string_scanner 1.0.4
tuple 1.0.2
typed_data 1.1.6
Dev dependencies
angel_test ^2.0.0-alpha
angel_validate ^2.0.0-alpha
logging any 0.11.3+2
oauth2 ^1.0.0
test ^1.0.0
uuid ^1.0.0 1.0.3