angel_orm 1.0.0-alpha+11

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 34

angel_orm

Runtime support for Angel's ORM. Includes SQL expression generators, as well as a friendly PostgreSQLConnectionPool class that you can use to pool connections to a PostgreSQL database.

For documentation about the ORM, head to the main project repo: https://github.com/angel-dart/orm

1.0.0-alpha+10

  • Split into angel_orm.dart and server.dart. Prevents DDC failures.

1.0.0-alpha+7

  • Added a @belongsToMany annotation class.
  • Resolved #20. The PostgreSQLConnectionPool keeps track of which connections have been opened now.

1.0.0-alpha+6

  • DateTimeSqlExpressionBuilder will no longer automatically insert quotation marks around names.

1.0.0-alpha+5

  • Corrected a typo that was causing the aforementioned test failures. == becomes =.

1.0.0-alpha+4

  • Added a null-check in lib/src/query.dart#L24 to (hopefully) prevent it from crashing on Travis.

1.0.0-alpha+3

  • Added isIn, isNotIn, isBetween, isNotBetween to SqlExpressionBuilder and its subclasses.
  • Added a dependency on package:meta.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angel_orm: ^1.0.0-alpha+11

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angel_orm/angel_orm.dart';
  
Version Uploaded Documentation Archive
2.0.0-dev.14 Dec 8, 2018 Go to the documentation of angel_orm 2.0.0-dev.14 Download angel_orm 2.0.0-dev.14 archive
2.0.0-dev.13 Dec 8, 2018 Go to the documentation of angel_orm 2.0.0-dev.13 Download angel_orm 2.0.0-dev.13 archive
2.0.0-dev.12 Dec 3, 2018 Go to the documentation of angel_orm 2.0.0-dev.12 Download angel_orm 2.0.0-dev.12 archive
2.0.0-dev.11 Dec 3, 2018 Go to the documentation of angel_orm 2.0.0-dev.11 Download angel_orm 2.0.0-dev.11 archive
2.0.0-dev.10 Dec 3, 2018 Go to the documentation of angel_orm 2.0.0-dev.10 Download angel_orm 2.0.0-dev.10 archive
2.0.0-dev.9 Dec 3, 2018 Go to the documentation of angel_orm 2.0.0-dev.9 Download angel_orm 2.0.0-dev.9 archive
2.0.0-dev.8 Dec 3, 2018 Go to the documentation of angel_orm 2.0.0-dev.8 Download angel_orm 2.0.0-dev.8 archive
2.0.0-dev.7 Dec 3, 2018 Go to the documentation of angel_orm 2.0.0-dev.7 Download angel_orm 2.0.0-dev.7 archive
2.0.0-dev.6 Dec 3, 2018 Go to the documentation of angel_orm 2.0.0-dev.6 Download angel_orm 2.0.0-dev.6 archive
2.0.0-dev.5 Dec 1, 2018 Go to the documentation of angel_orm 2.0.0-dev.5 Download angel_orm 2.0.0-dev.5 archive

All 28 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
55
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
31
Overall:
Weighted score of the above. [more]
34
Learn more about scoring.

We analyzed this package on Dec 13, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms:

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 
 Because angel_orm depends on postgres >=0.9.1 <1.0.0-beta.1 which requires SDK version >=1.19.0 <2.0.0, version solving failed.

Health suggestions

Format lib/angel_orm.dart.

Run dartfmt to format lib/angel_orm.dart.

Format lib/server.dart.

Run dartfmt to format lib/server.dart.

Format lib/src/annotations.dart.

Run dartfmt to format lib/src/annotations.dart.

Format lib/src/migration.dart.

Run dartfmt to format lib/src/migration.dart.

Format lib/src/query.dart.

Run dartfmt to format lib/src/query.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use angel_orm.dart.

Package is pre-release. (-5 points)

Pre-release versions should be used with caution, their API may change in breaking ways.

Package is getting outdated. (-3.84 points)

The package was released 54 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0