angel_query_builder 1.0.0-alpha

  • README.md
  • Installing
  • Versions
  • 39

angel_query_builder

version 1.0.0-alpha build status

Angel services powered by package:query_builder. Easily add any database to your application, along with a fluent querying DSL.

Expect documentation soon.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angel_query_builder: ^1.0.0-alpha

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angel_query_builder/angel_query_builder.dart';
  
Version Uploaded Documentation Archive
1.0.0-alpha Jun 11, 2017 Go to the documentation of angel_query_builder 1.0.0-alpha Download angel_query_builder 1.0.0-alpha archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
46
Overall:
Weighted score of the above. [more]
39
Learn more about scoring.

We analyzed this package on Aug 20, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.11.8

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because angel_query_builder depends on query_builder >=0.0.1 which requires SDK version >=1.19.0 <2.0.0, version solving failed.

Fix platform conflicts.

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Maintain CHANGELOG.md.

Changelog entries help clients to follow the progress in your code.

Homepage does not exists.

We were unable to access https://github.com/angel-dart/data_store.git at the time of the analysis.

Package is getting outdated.

The package was released 62 weeks ago.

Package is pre-release.

Pre-release versions should be used with caution, their API may change in breaking ways.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use angel_query_builder.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0