angel_range 1.0.0

  • README.md
  • Installing
  • Versions
  • 0

range #

Pub build status coverage: 100%

Support for handling the Range headers using the Angel framework. Aiming for 100% compliance with the Range specification.

Installation #

In your pubspec.yaml:

dependencies:
  angel_framework: ^1.0.0
  angel_range: ^1.0.0

Usage #

The acceptRanges() function returns an Angel request handler. This is best used as a response finalizer.

Compression #

If you are using response compression in your application, make sure to add it after Range support. Save yourself a headache!

configureServer(Angel app) async {
  // Apply `Range` headers, if need be
  app.responseFinalizers.add(acceptRanges());
  
  // Support gzip, deflate compression
  app.responseFinalizers.addAll([gzip(), deflate()]);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angel_range: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angel_range/angel_range.dart';
  
Version Uploaded Documentation Archive
1.0.0 Jun 15, 2017 Go to the documentation of angel_range 1.0.0 Download angel_range 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0