angel_seeder 1.0.2

  • Installing
  • Versions
  • 68


version 1.0. build status

Straightforward data seeder for Angel services. This is an almost exact port of feathers-seeder, so its documentation should almost exactly match up here. Fortunately, I was also the one who made feathers-seeder, so if you ever need assistance, file an issue.


var app = new Angel()..use('/todos', new TodoService());

await app.configure(seed(
    new SeederConfiguration<Todo>(delete: false, count: 10, template: {
        'text': (Faker faker) => 'Clean your room, ${}!',
        'completed': false

NOTE: Don't await seeding at application startup; that's too slow. Instead, run it asynchronously.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  angel_seeder: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:angel_seeder/angel_seeder.dart';
Version Uploaded Documentation Archive
1.0.2 Nov 18, 2017 Go to the documentation of angel_seeder 1.0.2 Download angel_seeder 1.0.2 archive
1.0.1 Mar 12, 2017 Go to the documentation of angel_seeder 1.0.1 Download angel_seeder 1.0.1 archive
1.0.0 Feb 22, 2017 Go to the documentation of angel_seeder 1.0.0 Download angel_seeder 1.0.0 archive
0.0.0 Jan 29, 2017 Go to the documentation of angel_seeder 0.0.0 Download angel_seeder 0.0.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Aug 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.11.8


Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 Because angel_seeder depends on faker >=0.0.2 which requires SDK version <2.0.0, version solving failed.

Fix platform conflicts.

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.


Changelog entries help clients to follow the progress in your code.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use angel_seeder.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0