angel_seeder 1.0.2

  • README.md
  • Installing
  • Versions
  • 15

angel_seeder #

version 1.0. build status

Straightforward data seeder for Angel services. This is an almost exact port of feathers-seeder, so its documentation should almost exactly match up here. Fortunately, I was also the one who made feathers-seeder, so if you ever need assistance, file an issue.

Example #

var app = new Angel()..use('/todos', new TodoService());

await app.configure(seed(
    'todos',
    new SeederConfiguration<Todo>(delete: false, count: 10, template: {
        'text': (Faker faker) => 'Clean your room, ${faker.person.name()}!',
        'completed': false
    })));

NOTE: Don't await seeding at application startup; that's too slow. Instead, run it asynchronously.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angel_seeder: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angel_seeder/angel_seeder.dart';
  
Version Uploaded Documentation Archive
1.0.2 Nov 18, 2017 Go to the documentation of angel_seeder 1.0.2 Download angel_seeder 1.0.2 archive
1.0.1 Mar 12, 2017 Go to the documentation of angel_seeder 1.0.1 Download angel_seeder 1.0.1 archive
1.0.0 Feb 22, 2017 Go to the documentation of angel_seeder 1.0.0 Download angel_seeder 1.0.0 archive
0.0.0 Jan 29, 2017 Go to the documentation of angel_seeder 0.0.0 Download angel_seeder 0.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
30
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
15
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0