angel_serialize_builder 1.0.0-alpha+1

  • README.md
  • Installing
  • Versions
  • 41

angel_serialize_builder

Renamed to package:angel_serialize_generator.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angel_serialize_builder: ^1.0.0-alpha+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angel_serialize_builder/angel_serialize_builder.dart';
  
Version Uploaded Documentation Archive
1.0.0-alpha+1 Jul 10, 2017 Go to the documentation of angel_serialize_builder 1.0.0-alpha+1 Download angel_serialize_builder 1.0.0-alpha+1 archive
1.0.0-alpha Jul 10, 2017 Go to the documentation of angel_serialize_builder 1.0.0-alpha Download angel_serialize_builder 1.0.0-alpha archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
56
Overall:
Weighted score of the above. [more]
41
Learn more about scoring.

We analyzed this package on Aug 16, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.11.8

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because angel_serialize_builder depends on recase <2.0.0 which requires SDK version >=1.20.0 <2.0.0, version solving failed.

Fix platform conflicts.

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Maintain CHANGELOG.md.

Changelog entries help clients to follow the progress in your code.

Package is getting outdated.

The package was released 57 weeks ago.

Package is pre-release.

Pre-release versions should be used with caution, their API may change in breaking ways.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use angel_serialize_builder.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0