angel_sync 1.0.0

  • README.md
  • Installing
  • Versions
  • 6

sync

Pub build status

Easily synchronize and scale WebSockets using package:pub_sub.

Usage

This package exposes PubSubWebSocketSynchronizer, which can simply be dropped into any AngelWebSocket constructor.

Once you've set that up, instances of your application will automatically fire events in-sync. That's all you have to do to scale a real-time application with Angel!

await app.configure(new AngelWebSocket(
    synchronizer: new PubSubWebSocketSynchronizer(
        new pub_sub.IsolateClient('<client-id>', adapter.receivePort.sendPort),
    ),
));

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angel_sync: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angel_sync/angel_sync.dart';
  
Version Uploaded Documentation Archive
1.0.0 Aug 8, 2017 Go to the documentation of angel_sync 1.0.0 Download angel_sync 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
32
Overall:
Weighted score of the above. [more]
6
Learn more about scoring.

We analyzed this package on Oct 15, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.12.4

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because angel_sync depends on pub_sub <2.0.0 which requires SDK version >=1.19.0 <2.0.0, version solving failed.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

Package is getting outdated. (-18.36 points)

The package was released 61 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use angel_sync.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0