angel_task 1.0.0

  • README.md
  • Installing
  • Versions
  • 0

task #

version 1.0.0

Support for running and scheduling asynchronous tasks within Angel.

Coming soon: Trigger tasks within route handlers. This will require communication between isolates, and will be present by the next release!

main() async {
  var app = await createApp();
  var scheduler = new AngelTaskScheduler(app);

  scheduler.once((Todo singleton) {
    print('3 seconds later, we found our Todo singleton: "${singleton.text}"');
  }, new Duration(seconds: 3));

  Task foo;
  int i = 0;

  foo = scheduler.seconds(1, () {
    print('Printing ${++i} time(s)!');

    if (i >= 3 && false) {
      print('Cancelling foo task...');
      foo.cancel();
    }
  });

  await scheduler.start();
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angel_task: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angel_task/angel_task.dart';
  
Version Uploaded Documentation Archive
1.1.1 Nov 18, 2017 Go to the documentation of angel_task 1.1.1 Download angel_task 1.1.1 archive
1.1.0+1 Jul 9, 2017 Go to the documentation of angel_task 1.1.0+1 Download angel_task 1.1.0+1 archive
1.1.0 Jul 9, 2017 Go to the documentation of angel_task 1.1.0 Download angel_task 1.1.0 archive
1.0.0 Mar 1, 2017 Go to the documentation of angel_task 1.0.0 Download angel_task 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

This package version is not analyzed, because it is more than two years old. Check the latest stable version for its analysis.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0