angel_user_agent 1.0.1

  • Installing
  • Versions
  • 1

user_agent #

Middleware to inject a User Agent object into requests. For convenience's sake, it also exports the user_agent library.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  angel_user_agent: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:angel_user_agent/angel_user_agent.dart';
Version Uploaded Documentation Archive
2.0.0 Sep 11, 2018 Go to the documentation of angel_user_agent 2.0.0 Download angel_user_agent 2.0.0 archive
1.0.1 Jan 25, 2017 Go to the documentation of angel_user_agent 1.0.1 Download angel_user_agent 1.0.1 archive
1.0.0 Jan 14, 2017 Go to the documentation of angel_user_agent 1.0.0 Download angel_user_agent 1.0.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

This package version is not analyzed, because it is more than two years old. Check the latest stable version for its analysis.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 Because angel_user_agent depends on user_agent <2.0.0 which requires SDK version >=1.0.0 <2.0.0, version solving failed.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Maintain (-20 points)

Changelog entries help clients to follow the progress in your code.

Package is getting outdated. (-96.99 points)

The package was released 102 weeks ago.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use angel_user_agent.dart. Packages with multiple examples should use example/


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0