angular2_google_signin 0.1.0+2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

Deprecated. Moved to https://pub.dartlang.org/packages/ng2_g_signin

angular2_google_signin

Angular2 Dart google sign-in component.

This package consists of

  • The dart interop code of Google Sign-In JavaScript client (using package:js).
  • Angular2 component to wrap the interop code.

For more information about Google Sign-In JavaScript client, See https://developers.google.com/identity/sign-in/web/sign-in

Usage

Add this script tag below in the head tag of web/index.html

<script src="https://apis.google.com/js/platform.js" async defer></script>

Import this in a ng2 component and add GoogleSignin on the directives.

import 'package:angular2_google_signin/angular2_google_signin.dart';

@Component(
    selector: 'app-component',
    templateUrl: 'template/app_component.html',
    directives: const [GoogleSignin]
)
class AppComponent {

  onGoogleSigninSuccess(GoogleSignInSuccess event) async {
    GoogleUser googleUser = event.googleUser;
    String id = googleUser.getId();
    assert(googleUser.isSignedIn());
    BasicProfile profile = googleUser.getBasicProfile();
    print('ID: ' + profile.getId()); // Do not send to your backend! Use an ID token instead.
    assert(profile.getId() == id);
    print('Name: ' + profile.getName());
    print('Image URL: ' + profile.getImageUrl());
    print('Email: ' + profile.getEmail());
    AuthResponse response = googleUser.getAuthResponse();
    print('id_token: ' + response.id_token);
    print('access_token: ' + response.access_token.toString());
    print('login_hint: ' + response.login_hint);
    print('scope: ' + response.scope.toString());
    print('expires_in: ' + response.expires_in.toString());
    print('first_issued_at: ' + response.first_issued_at.toString());
    print('expires_at: ' + response.expires_at.toString());
    GoogleAuth auth =  getAuthInstance();
    GoogleUser user = auth.currentUser.get();
    assert(user.hashCode == googleUser.hashCode);
    await auth.signOut();
    print('User signed out.');
  }
}

In a ng2 component template, put <google-signin> with attributes of render options and init params. clientId attribute is required. You don't need to write google-signin-client_id meta tag.

<google-signin clientId="..." width="240" theme="dark" scope="email profile" longTitle="true"
                 (googleSigninSuccess)="onGgoogleSigninSuccess($event)"></google-signin>

Also see example/.

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.1.0+2

0.1.0+1

  • Clean up code, fix README, and update deps.

0.1.0

  • Publish with example (still no test code).

0.0.1

  • Initial version, supporting basic features.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angular2_google_signin: ^0.1.0+2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angular2_google_signin/angular2_google_signin.dart';
  
Version Uploaded Documentation Archive
0.1.0+2 Mar 22, 2016 Go to the documentation of angular2_google_signin 0.1.0+2 Download angular2_google_signin 0.1.0+2 archive
0.1.0+1 Mar 21, 2016 Go to the documentation of angular2_google_signin 0.1.0+1 Download angular2_google_signin 0.1.0+1 archive
0.1.0 Mar 18, 2016 Go to the documentation of angular2_google_signin 0.1.0 Download angular2_google_signin 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.13.1 <2.0.0