angular2_title_by_route_service 0.0.1

  • Installing
  • Versions
  • 0

angular2_title_by_route_service #

Pub Travis

An Angular2 service for setting document titles on Route changes.

Usage #

Provide TitleByRouteService, e.g.

    providers: const [

and inject the same into your component, e.g.

  AppComponent(TitleByRouteService _titleSet) { }

By default, TitleRouteService will update the document title to the route name on route changes. A custom name strategy can be utilized instead by setting the nameStrategy field. Example:

  AppComponent(TitleByRouteService _titleSet) {
    _titleSet.nameStrategy = _setTitle;

  String _setTitle(String name, RouteData routeData, Map<String,String> params) {
    StringBuffer sb = new StringBuffer();
    sb.write("Title Set Demo | ");

    if ('title')) { // if title is in data, use it
    } else { //otherwise use route name

    if (params.containsKey('id')) { // if detail id in params, append it
      sb.write(": ${params['id']}");
    return sb.toString();

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Changelog #

0.0.1 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  angular2_title_by_route_service: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:angular2_title_by_route_service/angular2_title_by_route_service.dart';
Version Uploaded Documentation Archive
0.0.1 Dec 2, 2016 Go to the documentation of angular2_title_by_route_service 0.0.1 Download angular2_title_by_route_service 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.13.0 <2.0.0