angular_analyzer_plugin 0.0.17+4

  • README.md
  • Installing
  • Versions
  • 83

AngularDart analyzer plugin

A plugin for the Dart analyzer library package providing AngularDart support.

Features and bugs

Please file feature requests and bugs at the issue tracker.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angular_analyzer_plugin: ^0.0.17+4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angular_analyzer_plugin/angular_analyzer_plugin.dart';
  
Version Uploaded Documentation Archive
0.0.17+4 Nov 15, 2018 Go to the documentation of angular_analyzer_plugin 0.0.17+4 Download angular_analyzer_plugin 0.0.17+4 archive
0.0.17+3 Aug 14, 2018 Go to the documentation of angular_analyzer_plugin 0.0.17+3 Download angular_analyzer_plugin 0.0.17+3 archive
0.0.17+2 Aug 11, 2018 Go to the documentation of angular_analyzer_plugin 0.0.17+2 Download angular_analyzer_plugin 0.0.17+2 archive
0.0.17+1 Aug 3, 2018 Go to the documentation of angular_analyzer_plugin 0.0.17+1 Download angular_analyzer_plugin 0.0.17+1 archive
0.0.17 Jul 25, 2018 Go to the documentation of angular_analyzer_plugin 0.0.17 Download angular_analyzer_plugin 0.0.17 archive
0.0.16 Jul 3, 2018 Go to the documentation of angular_analyzer_plugin 0.0.16 Download angular_analyzer_plugin 0.0.16 archive
0.0.15+1 Apr 17, 2018 Go to the documentation of angular_analyzer_plugin 0.0.15+1 Download angular_analyzer_plugin 0.0.15+1 archive
0.0.15 Apr 17, 2018 Go to the documentation of angular_analyzer_plugin 0.0.15 Download angular_analyzer_plugin 0.0.15 archive
0.0.14 Mar 26, 2018 Go to the documentation of angular_analyzer_plugin 0.0.14 Download angular_analyzer_plugin 0.0.14 archive
0.0.13 Feb 13, 2018 Go to the documentation of angular_analyzer_plugin 0.0.13 Download angular_analyzer_plugin 0.0.13 archive

All 14 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
97
Health:
Code health derived from static analysis. [more]
87
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
40
Overall:
Weighted score of the above. [more]
83
Learn more about scoring.

We analyzed this package on Dec 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:angular_analyzer_plugin/angular_analyzer_plugin.dart.

Health suggestions

Fix lib/src/resolver.dart. (-3.45 points)

Analysis of lib/src/resolver.dart reported 7 hints, including:

line 1296 col 34: 'bestType' is deprecated and shouldn't be used.

line 1652 col 34: 'bestType' is deprecated and shouldn't be used.

line 1795 col 36: 'bestType' is deprecated and shouldn't be used.

line 1838 col 51: 'bestType' is deprecated and shouldn't be used.

line 1844 col 57: 'bestType' is deprecated and shouldn't be used.

Fix lib/src/standard_components.dart. (-2.96 points)

Analysis of lib/src/standard_components.dart reported 6 hints, including:

line 55 col 25: 'element' is deprecated and shouldn't be used.

line 88 col 30: 'element' is deprecated and shouldn't be used.

line 91 col 34: 'element' is deprecated and shouldn't be used.

line 327 col 35: 'element' is deprecated and shouldn't be used.

line 328 col 42: 'element' is deprecated and shouldn't be used.

Fix lib/src/directive_extraction.dart. (-2.48 points)

Analysis of lib/src/directive_extraction.dart reported 5 hints:

line 168 col 45: 'element' is deprecated and shouldn't be used.

line 240 col 47: 'element' is deprecated and shouldn't be used.

line 519 col 37: 'element' is deprecated and shouldn't be used.

line 523 col 25: 'element' is deprecated and shouldn't be used.

line 525 col 25: 'element' is deprecated and shouldn't be used.

Fix additional 7 files with analysis or formatting issues. (-4.50 points)

Additional issues in the following files:

  • lib/src/angular_driver.dart (2 hints)
  • lib/src/pipe_extraction.dart (2 hints)
  • lib/errors.dart (1 hint)
  • lib/plugin.dart (1 hint)
  • lib/src/completion.dart (1 hint)
  • lib/src/from_file_prefixed_error.dart (1 hint)
  • lib/src/view_extraction.dart (1 hint)

Maintenance issues and suggestions

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use angular_analyzer_plugin.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.0.0 <3.0.0
analyzer 0.33.1 0.33.1 0.34.0
analyzer_plugin 0.0.1-alpha.5 0.0.1-alpha.5
angular_ast ^0.5.0 0.5.7 0.5.8
crypto >=1.1.1 <3.0.0 2.0.6
meta ^1.0.2 1.1.6
plugin ^0.2.0 0.2.0+3
yaml ^2.1.2 2.1.15
Transitive dependencies
args 1.5.1
async 2.0.8
charcode 1.1.2
collection 1.14.11
convert 2.0.2
csslib 0.14.6
front_end 0.1.6+1 0.1.7
glob 1.1.7
html 0.13.3+3
kernel 0.3.6+1 0.3.7
logging 0.11.3+2
package_config 1.0.5
path 1.6.2
pub_semver 1.4.2
source_span 1.4.1
string_scanner 1.0.4
typed_data 1.1.6
utf 0.9.0+5
watcher 0.9.7+10
Dev dependencies
mockito ^3.0.0
test ^1.2.0
test_reflective_loader ^0.1.0