angular_barcode 0.0.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 13

angular_barcode

Draw Barcode or QrCode with Angular 2 dart

Usage

A simple usage example:

<angular-barcode value="1234567890128" format="ean13"></angular-barcode>
<angular-qrcode data="1234567890128" size="200" color="0000ff"></angular-qrcode>

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.2

  • Add QrCode

0.0.1

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angular_barcode: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angular_barcode/angular_barcode.dart';
  
Version Uploaded Documentation Archive
0.0.3 Sep 28, 2017 Go to the documentation of angular_barcode 0.0.3 Download angular_barcode 0.0.3 archive
0.0.2 Dec 12, 2016 Go to the documentation of angular_barcode 0.0.2 Download angular_barcode 0.0.2 archive
0.0.1 Dec 11, 2016 Go to the documentation of angular_barcode 0.0.1 Download angular_barcode 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
27
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
13
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0