angular_cli 0.1.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 6

AngularDart CLI

Pub Package Build Status

A command line interface for AngularDart. It can scaffold a skeleton AngularDart project, component, and test with page object.

Installation

To install:

pub global activate angular_cli

To update:

pub global activate angular_cli

Usage

ngdart help

For help on specific command, run ngdart help [command name] For example:

ngdart help generate test

will show how to use command generate test.

Generating AngularDart project

ngdart new project_name
cd project_name
pub get
pub serve

Navigate to http://localhost:8080 to visit the project you just built. Command following will assume that you are in the root directory of the project.

Generating component

ngdart generate component AnotherComponent

This command will generate component under folder lib/. You can use option -p to change the folder.

Generating test

ngdart generate test lib/app_component.dart

Command above will generate 2 files. One is page object file and the other one is test file. Test generated is using angular_test and test package.

Use command

pub run angular_test --test-arg=--tags=aot --test-arg=--platform=dartium  --test-arg=--reporter=expanded

to run generated test with Dartium.

Changelog

0.1.2

  • Added support for generate directive
  • Added support for generate pipe

0.1.1

  • Fixed issues on Windows.

0.1.0+3

  • Exported visitors which can be used to extract info from Dart files.

0.1.0+2

  • Fixed an issue on README.md formatting.
  • Enabled travis.

0.1.0+1

  • Added missing dependencies.

0.1.0

  • New implementation, support to create project, generate AngularDart component and test.

0.0.2

  • Fixed scaffold command so that it uses the correct platform separator. Instead of creating files in the CWD, it creates them in $name/lib and $name/test of the CWD.

0.0.1

  • Added scaffold command, which generates all of the files need for a component. This should be run from an empty folder and provider a selector name like my-foo-bar.

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate angular_cli

2. Use it

The package has the following executables:


$ ngdart

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angular_cli: ^0.1.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angular_cli/visitors.dart';
  
Version Uploaded Documentation Archive
0.1.2 Oct 9, 2017 Go to the documentation of angular_cli 0.1.2 Download angular_cli 0.1.2 archive
0.1.1 Sep 29, 2017 Go to the documentation of angular_cli 0.1.1 Download angular_cli 0.1.1 archive
0.1.0+3 Sep 28, 2017 Go to the documentation of angular_cli 0.1.0+3 Download angular_cli 0.1.0+3 archive
0.1.0+2 Sep 28, 2017 Go to the documentation of angular_cli 0.1.0+2 Download angular_cli 0.1.0+2 archive
0.1.0+1 Sep 27, 2017 Go to the documentation of angular_cli 0.1.0+1 Download angular_cli 0.1.0+1 archive
0.1.0 Sep 27, 2017 Go to the documentation of angular_cli 0.1.0 Download angular_cli 0.1.0 archive
0.0.2 Sep 3, 2017 Go to the documentation of angular_cli 0.0.2 Download angular_cli 0.0.2 archive
0.0.1 Sep 3, 2017 Go to the documentation of angular_cli 0.0.1 Download angular_cli 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
11
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
6
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0 <2.0.0