angular_fire 0.2.1

  • Installing
  • Versions
  • 64


An unofficial library for AngularDart and Firebase.

pub package Build Status


The current stable release of angular_fire works best with the following:

  angular2: ^3.1.0
  angular_fire: ^0.1.0
  firebase: ^3.1.0

To get started, you need to, at minimum, include the Firebase SDK:

  <script src=""></script>




A high-level authentication service. First setup for dependency injection:

import 'package:angular2/angular2.dart';
import 'package:angular2/platform/browser.dart';
import 'package:angular_fire/angular_fire.dart';
import 'package:firebase/firebase.dart' as sdk;

main() {
  bootstrap(AngularFireExample, <dynamic>[
      useValue: new FirebaseAuth(
          apiKey: '...',
          authDomain: '...',
          databaseURL: '...',
          storageBucket: '...',

Then inject into your app and use. See GoogleSignInComponent below for an example.



Displays a rendered sign in box for Google authentication that follows the branding guidelines.

import 'package:angular2/angular2.dart';
import 'package:angular_fire/angular_fire.dart';

  selector: 'angular-fire-example',
  directives: const [
  template: r'''
    <google-sign-in (trigger)="signIn()">
class AngularFireExample {
  final FirebaseAuth _auth;
  void onTrigger() {

NOTE: To use this component, you must have the brand assets in your web/assets directory, or use the [assetPath] property, or the googleSignInAssetPath token at bootstrap time to configure the location of your assets - for example on an external CDN.


Like ngIf, but shows content if the value matches the current authentication:

<div *ifFirebaseAuth="true; let currentUser = currentUser">
  Logged in as: {{currentUser.displayName}}.
  <button (click)="signOut()">Sign Out</button>

<div *ifFirebaseAuth="false">
  Waiting for sign in...




We welcome a diverse set of contributions, including, but not limited to:

For the stability of the API and existing users, consider opening an issue first before implementing a large new feature or breaking an API. For smaller changes (like documentation, bug fixes), just send a pull request.


Run the (simple) test suite in Dartium. It doesn't currently run on Travis:

$ pub run angular_test -p dartium


  • Add an option to add additional authorization scopes to googleSignIn:
// Authenticate and allow read-only access to Google Calendar.
final user = await firebaseAuth.googleSignIn(
  scopes: [

if (user != null) {
  // You have access!


  • Fixed a bug that flashed signed off content before loading.
  • Changed the default behavior of Google sign-in to prompt for account:
abstract class FirebaseAuth {
  Future<FirebaseUser> googleSignIn({bool prompt: true});


  • Removed a print statement that was always occurring.
  • Added a high-level FirebaseAuth class, and Google sign-in.
  • Added IfFirebaseAuthDirective.


  • Initial commit of GoogleSignInComppnent.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  angular_fire: "^0.2.1"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:angular_fire/angular_fire.dart';
Version Uploaded Documentation Archive
0.2.1 Jun 1, 2017 Go to the documentation of angular_fire 0.2.1 Download angular_fire 0.2.1 archive
0.2.0 Jun 1, 2017 Go to the documentation of angular_fire 0.2.0 Download angular_fire 0.2.0 archive
0.1.1 May 30, 2017 Go to the documentation of angular_fire 0.1.1 Download angular_fire 0.1.1 archive
0.1.0 May 30, 2017 Go to the documentation of angular_fire 0.1.0 Download angular_fire 0.1.0 archive


We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
31 / 100
Code health derived from static analysis. [more]
99 / 100
Reflects how tidy and up-to-date the package is. [more]
95 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: web

Primary library: package:angular_fire/angular_fire.dart with components: html.


  • Package is getting outdated.

    The package was released 54 weeks ago.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use angular_fire.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 2 hints.

    Strong-mode analysis of lib/src/components/google_sign_in.dart gave the following hint:

    line: 8 col: 1
    'angular2' is deprecated and shouldn't be used.

    Strong-mode analysis of lib/src/directives/firebase_auth.dart gave the following hint:

    line: 7 col: 1
    'angular2' is deprecated and shouldn't be used.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.22.0 <2.0.0
angular2 ^3.0.0 3.1.0+1
firebase ^3.0.0 3.2.0 4.5.0
meta ^1.0.5 1.1.5
Transitive dependencies
analyzer 0.30.0+4 0.32.1
args 0.13.7 1.4.3
async 2.0.7
barback 0.15.2+16
browser 0.10.0+3
build 0.9.3 0.12.6
build_barback 0.2.2 0.5.0+4
charcode 1.1.1
cli_util 0.1.3
code_builder 1.0.4 3.1.0
code_transformers 0.5.1+5
collection 1.14.10
convert 2.0.1
crypto 2.0.5
csslib 0.13.7+1 0.14.4
dart_style 1.0.9+1 1.1.0
fixnum 0.10.7
front_end 0.1.0-alpha.4.1 0.1.1
func 1.0.0
glob 1.1.5
html 0.13.3+1
http 0.11.3+16
http_parser 3.1.2
intl 0.15.6
isolate 1.1.0 2.0.1
js 0.6.1
kernel 0.3.0-alpha.1.1 0.3.1
logging 0.11.3+1
matcher 0.12.3
package_config 1.0.3
path 1.6.1
plugin 0.2.0+2
pool 1.3.5
protobuf 0.5.5 0.9.0
quiver 0.25.0 0.29.0+1
source_gen 0.5.10+1 0.8.2
source_maps 0.10.5
source_span 1.4.0
stack_trace 1.9.2
string_scanner 1.0.2
typed_data 1.1.5
utf 0.9.0+4
watcher 0.9.7+8
yaml 2.1.14
Dev dependencies
angular_test 1.0.0-beta+1
dart_to_js_script_rewriter ^1.0.1
test ^0.12.20+8