angular_forms 1.0.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 48

angular_forms

Pub Package

The Angular Forms framework.

This is just a port of the forms components that was in the core angular package, in order to break angular into smaller, independent packages.

1.0.0

  • Support for angular 4.0.0.

0.1.0

  • Initial commit of angular_forms.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angular_forms: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angular_forms/angular_forms.dart';
  
Version Uploaded Documentation Archive
2.1.1 Dec 10, 2018 Go to the documentation of angular_forms 2.1.1 Download angular_forms 2.1.1 archive
2.1.0 Oct 10, 2018 Go to the documentation of angular_forms 2.1.0 Download angular_forms 2.1.0 archive
2.0.0 Aug 7, 2018 Go to the documentation of angular_forms 2.0.0 Download angular_forms 2.0.0 archive
1.0.0 Aug 30, 2017 Go to the documentation of angular_forms 1.0.0 Download angular_forms 1.0.0 archive
0.1.0 Aug 15, 2017 Go to the documentation of angular_forms 0.1.0 Download angular_forms 0.1.0 archive
2.0.0-beta+3 Aug 2, 2018 Go to the documentation of angular_forms 2.0.0-beta+3 Download angular_forms 2.0.0-beta+3 archive
2.0.0-beta+2 Jul 19, 2018 Go to the documentation of angular_forms 2.0.0-beta+2 Download angular_forms 2.0.0-beta+2 archive
2.0.0-beta+1 Jul 16, 2018 Go to the documentation of angular_forms 2.0.0-beta+1 Download angular_forms 2.0.0-beta+1 archive
2.0.0-beta Jun 29, 2018 Go to the documentation of angular_forms 2.0.0-beta Download angular_forms 2.0.0-beta archive
2.0.0-alpha+7 Jun 15, 2018 Go to the documentation of angular_forms 2.0.0-alpha+7 Download angular_forms 2.0.0-alpha+7 archive

All 25 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
96
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0 <2.0.0