angular_mdl 0.1.7

  • Installing
  • Versions
  • 27

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angular_mdl: "^0.1.7"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angular_mdl/mdl.dart';

import 'package:angular_mdl/mdlcomponents.dart';
        
Version Uploaded Documentation Archive
0.1.7 Jul 24, 2017 Go to the documentation of angular_mdl 0.1.7 Download angular_mdl 0.1.7 archive

Analysis

We analyzed this package on Apr 9, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.46.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
12 / 100
Health:
Code health derived from static analysis. [more]
23 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
67 / 100
Overall score:
Weighted score of the above. [more]
27
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in libraries.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Maintain README.md.

    Readme should inform others about your project, what it does, and how they can use it.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 16 errors 3 warnings 13 hints.

    Strong-mode analysis of lib/src/components/MdlBadges.dart failed with the following error:

    line: 44 col: 51
    Undefined name 'buttonClasses'.

    Strong-mode analysis of lib/src/components/MdlButton.dart failed with the following error:

    line: 26 col: 171
    Two keys in a map literal can't be equal.

    Similar analysis of the following files failed:

    • lib/src/components/MdlLayout.dart (error)
    • lib/src/components/MdlTable.dart (error)
    • lib/src/components/MdlTextField.dart (error)
    • lib/mdl.dart (hint)
    • lib/mdlcomponents.dart (hint)
  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use angular_mdl.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0 <2.0.0
angular ^4.0.0-alpha+1 4.0.0+2 5.0.0-alpha+9
uuid ^0.5.3 0.5.3
Transitive dependencies
analyzer 0.30.0+4 0.31.1
angular_compiler 0.3.0+1 0.4.0-alpha+9
args 1.4.1
async 2.0.6
barback 0.15.2+15
build 0.11.2 0.12.1
build_barback 0.4.0+2 0.5.0+3
charcode 1.1.1
cli_util 0.1.2+1
code_builder 1.0.4 3.0.3
code_transformers 0.5.1+4
collection 1.14.9
convert 2.0.1
crypto 2.0.2+1
csslib 0.14.1
dart_style 1.0.9+1 1.0.10
front_end 0.1.0-alpha.4.1 0.1.0-alpha.11
func 1.0.0
glob 1.1.5
html 0.13.3
intl 0.15.4
isolate 1.1.0 2.0.0
js 0.6.1
kernel 0.3.0-alpha.1.1 0.3.0-alpha.11
logging 0.11.3+1
matcher 0.12.1+4
meta 1.1.2
package_config 1.0.3
path 1.5.1
plugin 0.2.0+2
pool 1.3.4
quiver 0.25.0 0.29.0+1
quiver_hashcode 1.0.0
source_gen 0.7.5+1 0.8.0
source_maps 0.10.4
source_span 1.4.0
stack_trace 1.9.2
string_scanner 1.0.2
tuple 1.0.1
typed_data 1.1.5
utf 0.9.0+4
watcher 0.9.7+7
yaml 2.1.13