angular_modern_charts 0.0.18

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 58

Angular modern charts

Angular wrapper for the modern_charts library

Changelog

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angular_modern_charts: "^0.0.18"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:angular_modern_charts/angular_modern_charts.dart';
  
Version Uploaded Documentation Archive
0.0.18 Oct 19, 2017 Go to the documentation of angular_modern_charts 0.0.18 Download angular_modern_charts 0.0.18 archive
0.0.17 Oct 9, 2017 Go to the documentation of angular_modern_charts 0.0.17 Download angular_modern_charts 0.0.17 archive
0.0.16 Oct 8, 2017 Go to the documentation of angular_modern_charts 0.0.16 Download angular_modern_charts 0.0.16 archive
0.0.15 Sep 8, 2017 Go to the documentation of angular_modern_charts 0.0.15 Download angular_modern_charts 0.0.15 archive
0.0.14 Sep 8, 2017 Go to the documentation of angular_modern_charts 0.0.14 Download angular_modern_charts 0.0.14 archive
0.0.13 Sep 4, 2017 Go to the documentation of angular_modern_charts 0.0.13 Download angular_modern_charts 0.0.13 archive
0.0.12 Sep 3, 2017 Go to the documentation of angular_modern_charts 0.0.12 Download angular_modern_charts 0.0.12 archive
0.0.11 Aug 31, 2017 Go to the documentation of angular_modern_charts 0.0.11 Download angular_modern_charts 0.0.11 archive
0.0.10 Aug 29, 2017 Go to the documentation of angular_modern_charts 0.0.10 Download angular_modern_charts 0.0.10 archive
0.0.9 Aug 29, 2017 Go to the documentation of angular_modern_charts 0.0.9 Download angular_modern_charts 0.0.9 archive

All 14 versions...

Analysis

We analyzed this package on Jun 12, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.60.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
17 / 100
Health:
Code health derived from static analysis. [more]
97 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
99 / 100
Overall score:
Weighted score of the above. [more]
58
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:angular_modern_charts/angular_modern_charts.dart.

Suggestions

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 16 hints.

    Run dartfmt to format lib/angular_modern_charts.dart.

    Run dartfmt to format lib/src/components/barchart_component/barchart_component.dart.

    Similar analysis of the following files failed:

    • lib/src/components/gaugechart_component/gaugechart_component.dart (hint)
    • lib/src/components/linechart_component/linechart_component.dart (hint)
    • lib/src/components/piechart_component/piechart_component.dart (hint)
    • lib/src/components/radarchart_component/radarchart_component.dart (hint)
    • lib/src/models/barchart_data.dart (hint)
    • lib/src/models/barchart_properties.dart (hint)
    • lib/src/models/gaugechart_data.dart (hint)
    • lib/src/models/gaugechart_properties.dart (hint)
    • lib/src/models/linechart_data.dart (hint)
    • lib/src/models/linechart_properties.dart (hint)
    • lib/src/models/piechart_data.dart (hint)
    • lib/src/models/piechart_properties.dart (hint)
    • lib/src/models/radarchart_data.dart (hint)
    • lib/src/models/radarchart_properties.dart (hint)
  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use angular_modern_charts.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0 <2.0.0
angular ^4.0.0 4.0.0+2 5.0.0-alpha+14
angular_components ^0.8.0 0.8.0 0.9.0-alpha+13
modern_charts ^0.1.12 0.1.12
sass_builder ^1.0.1 1.2.0 2.0.1
Transitive dependencies
analyzer 0.30.0+4 0.32.1
angular_compiler 0.3.0+1 0.4.0-alpha+14
angular_forms 1.0.0 2.0.0-alpha+6
args 1.4.3
async 2.0.7
barback 0.15.2+14 0.15.2+16
build 0.11.2 0.12.6
build_barback 0.4.0+2 0.5.0+4
build_config 0.2.5 0.3.0
charcode 1.1.1
cli_repl 0.1.3
cli_util 0.1.3
code_builder 1.0.4 3.1.0
code_transformers 0.5.1+5
collection 1.14.10
convert 2.0.1
crypto 2.0.3
csslib 0.14.4
dart2_constant 1.0.1+dart2
dart_style 1.0.9+1 1.0.14
fixnum 0.10.7
front_end 0.1.0-alpha.4.1 0.1.1
func 1.0.0
glob 1.1.5
html 0.13.3+1
http 0.11.3+16
http_parser 3.1.2
intl 0.15.6
io 0.3.2+1
isolate 1.1.0 2.0.1
js 0.6.1
kernel 0.3.0-alpha.1.1 0.3.1
logging 0.11.3+1
matcher 0.12.2+1
meta 1.1.5
observable 0.20.4+3 0.22.1+3
package_config 1.0.3
package_resolver 1.0.3
path 1.6.0
perf_api 0.1.0
plugin 0.2.0+2
pool 1.3.5
quiver 0.25.0 0.29.0+1
quiver_hashcode 1.0.0
sass 1.5.1
scratch_space 0.0.2+1
source_gen 0.7.5+1 0.8.1+3
source_maps 0.10.5
source_span 1.4.0
stack_trace 1.9.2
string_scanner 1.0.2
tuple 1.0.1
typed_data 1.1.5
utf 0.9.0+4
uuid 0.5.3 1.0.0
watcher 0.9.7+8
yaml 2.1.14
Dev dependencies
browser ^0.10.0