angular_quill 0.0.6

  • Installing
  • Versions
  • 20

Angular Quill

An angular dart component for the Quill rich text editor

See it in action


And view the corresponding example source code.


Add the dependency to pub:

  angular_quill: ^0.0.4

Add the component to your template

            placeholder="Write something..."

Add quillDirectives to the directives on your app component

  selector: 'my-app',
  templateUrl: 'app_component.html',
  directives: const [COMMON_DIRECTIVES, quillDirectives],
class AppComponent {}

Include Quill JS and css files in your app html.

    <script src="packages/angular_quill/quill-1.2.4/quill.min.js"></script>
    <link rel="stylesheet" href="packages/angular_quill/quill-1.2.4/quill.snow.css">



  • Update README


  • Split example out of main repo


  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  angular_quill: ^0.0.6

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:angular_quill/angular_quill.dart';
Version Uploaded Documentation Archive
0.0.6 Sep 5, 2017 Go to the documentation of angular_quill 0.0.6 Download angular_quill 0.0.6 archive
0.0.5 Jun 19, 2017 Go to the documentation of angular_quill 0.0.5 Download angular_quill 0.0.5 archive
0.0.4 Jun 19, 2017 Go to the documentation of angular_quill 0.0.4 Download angular_quill 0.0.4 archive
0.0.3 Jun 19, 2017 Go to the documentation of angular_quill 0.0.3 Download angular_quill 0.0.3 archive
0.0.2 Jun 19, 2017 Go to the documentation of angular_quill 0.0.2 Download angular_quill 0.0.2 archive
0.0.1 Jun 19, 2017 Go to the documentation of angular_quill 0.0.1 Download angular_quill 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <2.0.0