The AngularDart router enables navigation from one view to the next as users perform application tasks.
The 1.0 version of
angular_router is just a port of the router that was in
angular package. Only critical bug fixes are planned for the 1.0
router. A significant refactoring is in progress, which is expected to result
in a 2.0 version of
angular_router. This is just a port of the router that was in the core angular package.
Add this to your package's pubspec.yaml file:
dependencies: angular_router: ^1.0.2
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|1.0.2||Aug 30, 2017|
|1.0.1||Aug 24, 2017|
|1.0.0||Aug 7, 2017|
|2.0.0-alpha+21||Dec 10, 2018|
|2.0.0-alpha+20||Oct 10, 2018|
|2.0.0-alpha+19||Aug 7, 2018|
|2.0.0-alpha+18||Aug 2, 2018|
|2.0.0-alpha+17||Jul 19, 2018|
|2.0.0-alpha+16||Jul 16, 2018|
|2.0.0-alpha+15||Jun 29, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc failed. (-10 points)
dartdoc runs without any issues.
|Dart SDK||>=1.24.0 <2.0.0|